ALM-44006 El tiempo de GC de proceso de Presto Worker excede el umbral (Para MRS 2.x o anterior)
Descripción
El sistema recoge el tiempo de GC del proceso de Presto Worker cada 30 segundos. Esta alarma se genera cuando el tiempo de GC excede el umbral (excede 5 segundos durante tres veces consecutivas). Puede cambiar el umbral seleccionando System > Configure Alarm Threshold > Service > Presto > Worker > Presto Garbage Collection Time > Garbage Collection Time of the Worker Process en MRS Manager. Esta alarma se borra cuando el tiempo de GC del proceso del trabajador es más corto que o igual al umbral.
Atributo
ID de alarma |
Gravedad de alarma |
Borrar automáticamente |
---|---|---|
44006 |
Grave |
Sí |
Parámetro
Parámetro |
Descripción |
---|---|
ServiceName |
Servicio para el que se genera la alarma. |
RoleName |
Rol para el que se genera la alarma. |
HostName |
Host para el que se genera la alarma. |
Impacto en el sistema
Si el tiempo de GC del proceso de Worker es demasiado largo, el rendimiento de ejecución del proceso de Worker se verá afectado y el proceso de Worker incluso no estará disponible.
Causas posibles
La memoria de pila del proceso de Worker se usa en exceso o se asigna de forma inadecuada, lo que provoca la ocurrencia frecuente del proceso de GC.
Procedimiento
- Comprueba la hora del GC.
- Vaya a la página de detalles del clúster y elija Alarms.
- Seleccione la alarma cuyo Alarm ID sea 44006. A continuación, compruebe la dirección IP y el nombre del rol de la instancia de Location.
- Elija Components > Presto > Instances > Worker (dirección IP del negocio de la instancia para la que se genera la alarma) > Customize > Presto Garbage Collection Time. Haga clic en OK para ver la hora de GC.
- Compruebe si el tiempo de GC del proceso de Worker es superior a 5 segundos.
- Elija Components > Presto > Service Configuration, y cambie Basic a All, y elija Presto > Worker Aumente el valor de -Xmx (memoria heap máxima) en el parámetro JAVA_OPTS en función de los requisitos del sitio.
- Verifique si la alarma se ha borrado.
- En caso afirmativo, no es necesario hacer nada más.
- Si no, vaya a 2.
- Recopilar información de fallas.
- En MRS Manager, seleccione .
- Póngase en contacto con el personal de O&M y envíe los registros recopilados.
Referencia
Ninguna