Estos contenidos se han traducido de forma automática para su comodidad, pero Huawei Cloud no garantiza la exactitud de estos. Para consultar los contenidos originales, acceda a la versión en inglés.
Actualización más reciente 2023-11-20 GMT+08:00

ALM-44005 El tiempo de GC del proceso del Presto Coordinator supera el umbral (Para MRS 2.x o anterior)

Descripción

El sistema recoge el tiempo de GC del proceso de Presto Coordinator cada 30 segundos. Esta alarma se genera cuando el tiempo de GC excede el umbral (excede 5 segundos durante tres veces consecutivas). Puede cambiar el umbral seleccionando System > Configure Alarm Threshold > Service > Presto > Coordinator > Presto Process Garbage Collection Time > Garbage Collection Time of the Coordinator Process en MRS Manager. Esta alarma se borra cuando el tiempo de proceso de GC del Coordinator es menor o igual que el umbral.

Atributo

ID de alarma

Severidad de alarma

Borrar automáticamente

44005

Grave

Parámetro

Parámetro

Descripción

ServiceName

Servicio para el que se genera la alarma.

RoleName

Rol para el que se genera la alarma.

HostName

Host para el que se genera la alarma.

Impacto en el sistema

Si el tiempo de GC del proceso del Coordinator es demasiado largo, el proceso del Coordinator se verá afectado y el proceso del Coordinator incluso no estará disponible.

Causas posibles

La memoria heap del proceso del Coordinator se utiliza en exceso o se asigna de manera inadecuada, lo que provoca la ocurrencia frecuente del proceso de GC.

Procedimiento

  1. Comprueba el tiempo de GC.

    1. Vaya a la página de detalles del clúster y elija Alarms.
    2. Seleccione la alarma cuyo Alarm ID sea 44005 y vea la dirección IP y el nombre del rol de la instancia de Location.
    3. Seleccione Components > Presto > Instances > Coordinator (dirección IP del negocio de la instancia para la que se genera la alarma) > Customize > Presto Garbage Collection Time. Haga clic en OK para ver la hora de GC.
    4. Compruebe si el tiempo de GC del proceso de Coordinator es superior a 5 segundos.
      • En caso afirmativo, vaya a 1.e.
      • Si no, vaya a 2.
    5. Seleccione Components > Presto > Service Configuration, y cambie Basic a All. Elija Presto > Coordinator. Aumente el valor de -Xmx en el parámetro JAVA_OPTS según los requisitos del sitio.
    6. Verifique si la alarma se ha borrado.
      • En caso afirmativo, no es necesario hacer nada más.
      • Si no, vaya a 2.

  2. Recopile información de fallas.

    1. En MRS Manager, seleccione System > Export Log.
    2. Póngase en contacto con el personal de O&M y envíe los registros recopilados.

Referencia

Ninguna