ALM-38000 Servicio Kafka no disponible (Para MRS 2.x o anterior)
Descripción
El sistema comprueba la disponibilidad del servicio Kafka cada 30 segundos. Esta alarma se genera si el servicio Kafka no está disponible.
Esta alarma se borra después de que se recupere el servicio Kafka.
Atributo
ID de alarma |
Severidad de alarma |
Borrar automáticamente |
---|---|---|
38000 |
Crítica |
Sí |
Parámetros
Parámetro |
Descripción |
---|---|
ServiceName |
Especifica el servicio para el que se genera la alarma. |
RoleName |
Especifica el rol para el que se genera la alarma. |
HostName |
Especifica el host para el que se genera la alarma. |
Impacto en el sistema
El clúster no puede proporcionar el servicio de Kafka y los usuarios no pueden ejecutar nuevas tareas de Kafka.
Causas posibles
- El componente KrbServer está defectuoso.
- El componente ZooKeeper está defectuoso o no responde.
- El nodo Broker en el clúster de Kafka es anormal.
Procedimiento
- Compruebe el estado del componente KrbServer. Para los clústeres sin autenticación de Kerberos, omita este paso y vaya a 2.
- Vaya a la página de detalles del clúster MRS y haga clic en Components.
- Compruebe si el estado de salud del servicio KrbServer es de tipo Good.
- Rectifique la falla siguiendo las instrucciones en ALM-25500 Servicio de KrbServer no disponible.
- Realice 1.b de nuevo.
- Compruebe el estado del componente de ZooKeeper.
- Compruebe el estado del Broker.
- Elija .
- En el Role, compruebe si todas las instancias son normales.
- Seleccione todas las instancias de Broker y elija .
- Elija . Compruebe si el estado de salud de Kafka es Good.
- Espere 30 segundos y compruebe si la alarma está desactivada.
- En caso afirmativo, no es necesario hacer nada más.
- Si no, vaya a 4.
- Recopilar información de fallas.
- En MRS Manager, seleccione .
- Póngase en contacto con el personal de O&M y envíe los registros recopilados.
Información relacionada
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