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Actualización más reciente 2023-11-20 GMT+08:00

ALM-28001 Servicio de Spark no disponible (Para MRS 2.x o anterior)

Descripción

El sistema comprueba el estado del servicio Spark cada 30 segundos. Esta alarma se genera cuando el servicio Spark no está disponible.

Esta alarma se borra cuando el servicio Spark se recupera.

Atributo

ID de alarma

Gravedad de alarma

Borrar automáticamente

28001

Crítica

Parámetros

Parámetro

Descripción

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Impacto en el sistema

Las tareas de Spark enviadas por los usuarios no se pueden ejecutar.

Causas posibles

  • El servicio KrbServer es anormal.
  • El servicio LdapServer es anormal.
  • El servicio ZooKeeper es anormal.
  • El servicio HDFS es anormal.
  • El servicio Yarn es anormal.
  • El servicio Hive correspondiente es anormal.

Procedimiento

  1. Compruebe si existen alarmas de indisponibilidad de servicio en los servicios de los que depende Spark.

    1. Vaya a la página de detalles del clúster de MRS y elija Alarms.
    2. Compruebe si existen las siguientes alarmas en la lista de alarmas:
      1. ALM-25500 Servicio KrbServer no disponible
      2. ALM-25000 Servicio LdapServer no disponible
      3. ALM-13000 Servicio ZooKeeper no disponible
      4. ALM-14000 Servicio HDFS no disponible
      5. ALM-18000 Servicio Yarn no disponible
      6. ALM-16004 Servicio Hive no disponible
      • En caso afirmativo, vaya a 1.c.
      • Si no, vaya a 2.
    3. Manejar las alarmas basándose en los métodos de solución de problemas proporcionados en la ayuda de alarma.

      Después de que la alarma esté desactivada, espere unos minutos y compruebe si la alarma Servicio HetuServer no disponible está borrada.

      • En caso afirmativo, no es necesario hacer nada más.
      • Si no, vaya a 2.

  2. Recopilar información de fallas.

    1. En MRS Manager, seleccione System > Export Log.
    2. Póngase en contacto con el personal de O&M y envíe los registros recopilados.

Referencia

Ninguna