Estos contenidos se han traducido de forma automática para su comodidad, pero Huawei Cloud no garantiza la exactitud de estos. Para consultar los contenidos originales, acceda a la versión en inglés.
Actualización más reciente 2023-11-20 GMT+08:00

ALM-26051 Servicio de Storm no disponible (Para MRS 2.x o anterior)

Descripción

El sistema comprueba la disponibilidad del servicio Storm cada 30 segundos. Esta alarma se genera si el servicio Storm no está disponible después de que todos los nodos Nimbus de un clúster se vuelven anormales.

Esta alarma se borra después de que el servicio Storm se recupere.

Atributo

ID de alarma

Severidad de alarma

Borrar automáticamente

26051

Crítica

Parámetros

Parámetro

Descripción

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Impacto en el sistema

  • El clúster no puede proporcionar el servicio Storm.
  • Los usuarios no pueden ejecutar tareas nuevas de Storm.

Causas posibles

  • El componente de Kerberos es defectuoso.
  • ZooKeeper está defectuoso o suspendido.
  • Los nodos de Nimbus activos y en espera en el clúster Storm son anormales.

Procedimiento

  1. Compruebe el estado del componente de Kerberos. Para los clústeres sin autenticación de Kerberos, omita este paso y vaya a 2.

    1. Vaya a la página de detalles del clúster MRS y haga clic en Components.
    2. Compruebe si el estado del servicio de Kerberos es de Good.
      • En caso afirmativo, vaya a 2.a.
      • Si no, vaya a 1.c.
    3. Rectifique la falla siguiendo las instrucciones en ALM-25500 Servicio de KrbServer no disponible.
    4. Realice 1.b de nuevo.

  2. Compruebe el estado del componente de ZooKeeper.

    1. Compruebe si el estado de salud del servicio ZooKeeper es Good.
      • En caso afirmativo, vaya a 3.a.
      • Si no, vaya a 2.b.
    2. Si se detiene el servicio de ZooKeeper, inícielo. Para otros problemas, siga las instrucciones en ALM-13000 Servicio de ZooKeeper no disponible.
    3. Realice 2.a de nuevo.

  3. Compruebe el estado de los nodos de Nimbus activos y en espera.

    1. Elija Components > Storm > Nimbus.
    2. En Role, compruebe si solo existe un nodo de Nimbus activo.
      • En caso afirmativo, vaya a 4.
      • Si no, vaya a 3.c.
    3. Seleccione las dos instancias de Nimbus y elija More > Restart Instance. Compruebe si el reinicio se realiza correctamente.
      • En caso afirmativo, vaya a 3.d.
      • Si no, vaya a 4.
    4. Inicie sesión de nuevo en MRS Manager y elija Components > Storm > Nimbus. Comprueba si el estado de salud de Nimbus es Good.
      • En caso afirmativo, vaya a 3.e.
      • Si no, vaya a 4.
    5. Espere 30 segundos y compruebe si la alarma está desactivada.
      • En caso afirmativo, no es necesario hacer nada más.
      • Si no, vaya a 4.

  4. Recopilar información de fallas.

    1. En MRS Manager, seleccione System > Export Log.
    2. Póngase en contacto con el personal de O&M y envíe los registros recopilados.

Información relacionada

N/A