ALM-19000 Servicio HBase no disponible (para MRS 2.x o anterior)
Descripción
El módulo de alarma comprueba el estado del servicio de HBase cada 30 segundos. Esta alarma se genera cuando el servicio HBase no está disponible.
Esta alarma se borra cuando se recupera el servicio HBase.
Atributo
ID de alarma |
Gravedad de alarma |
Borrar automáticamente |
---|---|---|
19000 |
Crítica |
Sí |
Parámetros
Parámetro |
Descripción |
---|---|
ServiceName |
Especifica el servicio para el que se genera la alarma. |
RoleName |
Especifica el rol para el que se genera la alarma. |
HostName |
Especifica el host para el que se genera la alarma. |
Impacto en el sistema
No se pueden realizar operaciones, como leer o escribir datos y crear tablas.
Causas posibles
- ZooKeeper es anormal.
- HDFS es anormal.
- HBase es anormal.
- Estado anormal de la red.
Procedimiento
- Compruebe el estado del ZooKeeper.
- Vaya a la página de detalles del clúster MRS y haga clic en Components.
- En la lista de servicios, compruebe si el estado de salud de ZooKeeper es de tipo Good.
- En la lista de alarmas, compruebe si existe la alarma ALM-13000 El servicio ZooKeeper no disponible.
- Rectifique la falla siguiendo los pasos proporcionados en ALM-13000 El servicio ZooKeeper no disponible.
- Espere varios minutos y compruebe si la alarma está desactivada.
- En caso afirmativo, no es necesario hacer nada más.
- Si no, vaya a 2.a.
- Compruebe el estado de HDFS.
- Recopilar información de fallas.
- En MRS Manager, seleccione .
- Póngase en contacto con el personal de O&M y envíe los registros recopilados.
Referencia
Ninguna