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Actualización más reciente 2023-11-20 GMT+08:00

ALM-19000 Servicio HBase no disponible (para MRS 2.x o anterior)

Descripción

El módulo de alarma comprueba el estado del servicio de HBase cada 30 segundos. Esta alarma se genera cuando el servicio HBase no está disponible.

Esta alarma se borra cuando se recupera el servicio HBase.

Atributo

ID de alarma

Gravedad de alarma

Borrar automáticamente

19000

Crítica

Parámetros

Parámetro

Descripción

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Impacto en el sistema

No se pueden realizar operaciones, como leer o escribir datos y crear tablas.

Causas posibles

  • ZooKeeper es anormal.
  • HDFS es anormal.
  • HBase es anormal.
  • Estado anormal de la red.

Procedimiento

  1. Compruebe el estado del ZooKeeper.

    1. Vaya a la página de detalles del clúster MRS y haga clic en Components.
    2. En la lista de servicios, compruebe si el estado de salud de ZooKeeper es de tipo Good.
      • En caso afirmativo, vaya a 2.a.
      • Si no, vaya a 1.c.
    3. En la lista de alarmas, compruebe si existe la alarma ALM-13000 El servicio ZooKeeper no disponible.
      • En caso afirmativo, vaya a 1.d.
      • Si no, vaya a 2.a.
    4. Rectifique la falla siguiendo los pasos proporcionados en ALM-13000 El servicio ZooKeeper no disponible.
    5. Espere varios minutos y compruebe si la alarma está desactivada.
      • En caso afirmativo, no es necesario hacer nada más.
      • Si no, vaya a 2.a.

  2. Compruebe el estado de HDFS.

    1. En MRS Manager, compruebe si se notifica la alarma ALM-14000 El servicio HDFS no disponible.
      • En caso afirmativo, vaya a 2.b.
      • Si no, vaya a 3.
    2. Rectifique la falla siguiendo los pasos proporcionados en ALM-14000 El servicio HDFS no disponible.
    3. Espere varios minutos y compruebe si la alarma está desactivada.

  3. Recopilar información de fallas.

    1. En MRS Manager, seleccione System > Export Log.
    2. Póngase en contacto con el personal de O&M y envíe los registros recopilados.

Referencia

Ninguna