ALM-18006 Tiempo de espera de ejecución de trabajos de MapReduce (Para MRS 2.x o anterior)
Descripción
El módulo de alarma comprueba la ejecución del trabajo de MapReduce cada 30 segundos. Esta alarma se genera cuando se agota el tiempo de ejecución de un trabajo de MapReduce enviado.
Esta alarma debe borrarse manualmente.
Atributo
ID de alarma |
Gravedad de la alarma |
Borrar automáticamente |
---|---|---|
18006 |
Grave |
No |
Parámetros
Parámetro |
Descripción |
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ServiceName |
Especifica el servicio para el que se genera la alarma. |
RoleName |
Especifica el rol para el que se genera la alarma. |
HostName |
Especifica el host para el que se genera la alarma. |
Trigger condition |
Genera una alarma cuando el valor real del indicador excede el umbral especificado. |
Impacto en el sistema
Se agota el tiempo de ejecución del trabajo de MapReduce enviado, por lo que no se puede obtener ningún resultado de ejecución. Ejecute el trabajo de nuevo después de rectificar la falla.
Causas posibles
Lleva mucho tiempo ejecutar un trabajo de MapReduce. Sin embargo, el tiempo especificado es menor que el tiempo de ejecución requerido.
Procedimiento
- Comprueba si el tiempo está ajustado incorrectamente.
- Compruebe el estado de Yarn.
- Vaya a la página de detalles del clúster y elija Alarms.
- En la lista de alarmas de MRS Manager, compruebe si se genera la alarma ALM-18000 servicio Yarn no disponible.
- Rectificar la falla siguiendo el procedimiento de tratamiento de ALM-18000 Servicio de Yarn no disponible (Para MRS 2.x o anterior).
- Vuelva a ejecutar el comando de trabajo de MapReduce para comprobar si se puede ejecutar el trabajo de MapReduce.
- En la lista de alarmas, haga clic en en la columna Operation de la alarma para borrarla manualmente. No se requiere ninguna otra acción.
- Ajuste el umbral de tiempo de espera.
En MRS Manager, elija System > Threshold Configuration > Services > Yarn > Timed out Applications y aumente el número máximo de tareas de tiempo de espera permitidas por la regla de umbral actual. Verifique si la alarma se ha borrado.
- De ser así, no se requiere ninguna acción adicional.
- Si no, vaya a 4.
- Recopile información de fallas.
- En MRS Manager, seleccione .
- Póngase en contacto con el personal de O&M y envíe los registros recopilados.
Referencia
Ninguna