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Actualización más reciente 2023-11-20 GMT+08:00

ALM-12041 El permiso de archivos clave es anormal (Para MRS 2.x o anterior)

Descripción

El sistema comprueba los permisos, los usuarios y los grupos de usuarios de los directorios o archivos clave cada hora. Esta alarma se genera si alguno de estos es anormal.

Esta alarma se borra después de resolver el problema que provoca permisos, usuarios o grupos de usuarios anormales.

Atributo

ID de alarma

Severidad de alarma

Borrar automáticamente

12041

Grave

Parámetros

Parámetro

Descripción

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

PathName

Especifica la ruta de acceso o el nombre del archivo.

Impacto en el sistema

Las funciones del sistema no están disponibles.

Causas posibles

El usuario ha modificado manualmente el permiso del archivo, la información del usuario o los grupos de usuarios, o el sistema ha experimentado un apagado inesperado.

Procedimiento

  1. Verifique el permiso del archivo.

    1. Vaya a la página de detalles del clúster de MRS y elija Alarms.
    2. En los detalles de la alarma, consulte el HostName (nombre del host con alarma) y el PathName (ruta o nombre del archivo involucrado).
    3. Inicie sesión en el nodo con alarma.
    4. Ejecute el comando ll PathName para consultar el usuario actual, el permiso y el grupo de usuarios del archivo o ruta de acceso.
    5. Vaya al directorio ${BIGDATA_HOME}/nodeagent/etc/agent/autocheck y ejecute el comando vi keyfile. Busque el nombre del archivo involucrado y consulte el permiso correcto del archivo.
    6. Compare el permiso real del archivo con el permiso obtenido en 1.e. Si son diferentes, cambie el permiso real, la información de usuario y el grupo de usuarios a los valores correctos.
    7. Espere hasta que se complete la siguiente comprobación del sistema y compruebe si la alarma está desactivada.
      • En caso afirmativo, no es necesario hacer nada más.
      • Si no, vaya a 2.

  2. Recopilar información de fallas.

    1. En MRS Manager, seleccione System > Export Log.
    2. Póngase en contacto con el personal de O&M y envíe los registros recopilados.

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