Estos contenidos se han traducido de forma automática para su comodidad, pero Huawei Cloud no garantiza la exactitud de estos. Para consultar los contenidos originales, acceda a la versión en inglés.
Actualización más reciente 2023-11-20 GMT+08:00

ALM-12004 Recurso OLdap anormal (Para MRS 2.x o anterior)

Descripción

Esta alarma se genera cuando el recurso Ldap en Manager es anormal.

Esta alarma se borra cuando se recupera el recurso Ldap en Manager y se completa el manejo de alarmas.

Atributo

ID de alarma

Severidad de alarma

Borrar automáticamente

12004

Grave

Parámetro

Parámetro

Descripción

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Impacto en el sistema

Los servicios de autenticación de Manager no están disponibles y no pueden proporcionar funciones de autenticación de seguridad y gestión de usuarios para los servicios web de capa superior. Es posible que los usuarios no puedan iniciar sesión en Manager.

Causas posibles

El proceso LdapServer en Manager es anormal.

Procedimiento

  1. Compruebe si el proceso LdapServer en Manager es normal.

    1. Inicie sesión en el nodo de gestión activo.
    2. Ejecute ps -ef | grep slapd para comprobar si el proceso de recursos LdapServer en el directorio ${BIGDATA_HOME}/om-0.0.1/ del archivo de configuración se está ejecutando correctamente.

      Puede determinar que el recurso es normal de la siguiente manera:

      1. Ejecute sh ${BIGDATA_HOME}/om-0.0.1/sbin/status-oms.sh y encuentre que el ResHAStatus del proceso OLdap es Normal.
      2. Ejecute ps -ef | grep slapd y encuentre que el proceso de slapd ocupa el puerto 21750.
      • En caso afirmativo, vaya a 2.
      • Si no, vaya a 3.

  2. Ejecute kill -2 PID of the LdapServer process y espere 20 segundos. El HA inicia el proceso OLdap automáticamente. Compruebe si el estado del recurso OLdap es normal.

    • En caso afirmativo, no es necesario hacer nada más.
    • Si no, vaya a 3.

  3. Recopilar información de fallas.

    1. En MRS Manager, seleccione System > Export Log.
    2. Póngase en contacto con el personal de O&M y envíe los registros recopilados.

Referencia

Ninguna