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Centro de ayuda> MapReduce Service> Guía del usuario> Referencia de alarma (aplicable a MRS 3.x)> ALM-45586 El uso de memoria de heap de IoTDBServer supera el umbral
Actualización más reciente 2023-11-20 GMT+08:00

ALM-45586 El uso de memoria de heap de IoTDBServer supera el umbral

Descripción

El sistema comprueba el estado del proceso IoTDBServer cada 60 segundos. La alarma se genera cuando el uso de memoria heap del proceso IoTDBServer excede el umbral (90% de la memoria máxima).

Atributo

ID de alarma

Severidad de alarma

Borrar automáticamente

45586

Grave

Parámetros

Nombre

Significado

Source

Especifica el clúster para el que se genera la alarma.

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Impacto en el sistema

Si la memoria heap de procesos IoTDBServer disponible es insuficiente, se produce un desbordamiento de memoria y el servicio se interrumpe.

Causas posibles

La memoria heap del proceso IoTDBServer se utiliza en exceso o la memoria heap se asigna de forma inadecuada.

Procedimiento

Comprobar el uso de memoria heap.

  1. Inicie sesión en FusionInsight Manager y elija O&M. En el panel de navegación de la izquierda, elija Alarm > Alarms. En la página que se muestra, busque la fila que contiene la alarma cuyo Alarm ID es 45586, vea el nombre del rol en Location y compruebe la dirección IP de la instancia.
  2. Elija Cluster > Name of the desired cluster > Service > IoTDB > Instance. Haga clic en IoTDBServer para el que se genera la alarma para ir a Dashboard. Haga clic en la lista desplegable en la esquina superior derecha del área del gráfico y elija Customize > Memory. En el cuadro de diálogo que se muestra, seleccione IoTDBServer Heap Memory Resource Percentage y haga clic en OK. Comprueba si la memoria no-heap utilizada por el proceso IoTDBServer alcanza el 90% (por defecto) de la memoria no-heap máxima especificada para IoTDBServer.

    • En caso afirmativo, vaya a 3.
    • Si no, vaya a 5.

  3. Elija Cluster > Name of the desired cluster > Service > IoTDB > Configuration, haga clic en All Configurations, elija IoTDBServer > System y aumente el valor de -Xmx en el parámetro GC_OPTS.

    • El valor predeterminado de Xmx es 2G.
    • Si esta alarma se genera ocasionalmente, aumente el valor en 0.5 veces. Si esta alarma se genera con frecuencia, duplique el valor.
    • En el caso de un gran volumen de servicio y una alta simultaneidad de servicio, se recomienda agregar instancias.

  4. Verifique si la alarma se ha borrado.

    • En caso afirmativo, no es necesario hacer nada más.
    • Si no, vaya a 5.

Recopilar información de fallas.

  1. En FusionInsight Manager, seleccione O&M. En el panel de navegación de la izquierda, elija Log > Download.
  2. Expanda la lista desplegable Service, seleccione IoTDB para el clúster de destino y haga clic en OK.
  3. Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 30 minutos antes y después del tiempo de generación de alarmas respectivamente. A continuación, haga clic en Download.
  4. Póngase en contacto con y proporcione los registros recopilados.

Eliminación de alarmas

Esta alarma se borra automáticamente después de rectificar la falla.

Información relacionada

Ninguna