ALM-45434 Existe una única réplica en la tabla de datos de ClickHouse
Descripción
Esta alarma se genera cuando se detecta una única réplica en un clúster lógico personalizado después de que el clúster lógico personalizado esté habilitado para ClickHouse.
Esta alarma se borra automáticamente cuando el sistema detecta que el clúster lógico personalizado utiliza varias réplicas.
Atributo
ID de alarma |
Severidad de alarma |
Borrar automáticamente |
---|---|---|
45434 |
Grave |
Sí |
Parámetros
Nombre |
Significado |
---|---|
Source |
Especifica el clúster o sistema para el que se genera la alarma. |
ServiceName |
Especifica el servicio para el que se genera la alarma. |
RoleName |
Especifica el rol para el que se genera la alarma. |
HostName |
Especifica el host para el que se genera la alarma. |
Impacto en el sistema
Si se produce un error de hardware, los datos no se pueden restaurar.
Causas posibles
El archivo metrika.xml del directorio de configuración ClickHouse contiene la configuración de réplica única.
Procedimiento
Compruebe si la configuración en metrika.xml de la instancia ClickHouse es correcta.
- En la lista de alarmas del FusionInsight Manager, busque la fila que contiene la alarma y haga clic en para ver el nombre del host para el que se genera la alarma. En la página Hosts, vea la dirección IP del host basada en el nombre del host.
- Inicie sesión en el host donde la instancia ClickHouse es anormal, vaya al directorio de configuración de la instancia ClickHouse y ejecute los siguientes comandos:
cd ${BIGDATA_HOME}/FusionInsight_ClickHouse_Version/x_x_ClickHouseServer/etc
cat metrika.xml
- Vea el número de particiones en cada clúster lógico personalizado y compruebe que existe una única réplica. A continuación, vaya a 4.
Si una partición contiene solo un nodo, existe una única réplica en un clúster lógico, como se muestra a continuación:
<shard> <internal_replication>true</internal_replication> <replica> <host>host-name1</host> <port>port</port> <user>clickhouse</user> <password/> </replica> </shard>
Recopilar información de fallas.
- En FusionInsight Manager, seleccione O&M. En el panel de navegación de la izquierda, elija Log > Download.
- Expanda la lista desplegable Service y seleccione ClickHouse para el clúster de destino.
- Expanda la lista desplegable Hosts. En el cuadro de diálogo Select Host que se muestra, seleccione el host anormal y haga clic en OK.
- Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 1 hora antes y después del tiempo de generación de alarma, respectivamente. A continuación, haga clic en Download.
- Póngase en contacto con y proporcione los registros recopilados.
Eliminación de alarmas
Esta alarma se borra automáticamente después de rectificar la falla.
Información relacionada
Ninguna