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Actualización más reciente 2023-11-20 GMT+08:00

ALM-45276 Estado anormal de RangerAdmin

Descripción

El módulo de alarma comprueba el estado del servicio RangerAdmin cada 60 segundos. Esta alarma se genera si RangerAdmin no está disponible.

Esta alarma se borra automáticamente una vez que se recupera el servicio RangerAdmin.

Atributos

ID de alarma

Severidad de alarma

Borrado automáticamente

45276

Grave

Parámetros

Nombre

Significado

Source

Clúster para el que se genera la alarma.

ServiceName

Servicio para el que se genera la alarma.

RoleName

Rol para el que se genera la alarma.

HostName

Host para el que se genera la alarma.

Impacto en el sistema

Si el estado de un RangerAdmin es anormal, el acceso a la interfaz de usuario nativa de Ranger no se ve afectado. Si hay dos instancias de RangerAdmin anormales, no se puede acceder a la interfaz de usuario nativa de Ranger y las operaciones como crear, modificar y eliminar políticas no están disponibles.

Causas posibles

El puerto RangerAdmin no se inicia.

Procedimiento

Comprobar el proceso de puerto.

  1. En la lista de alarmas del FusionInsight Manager, busque la fila que contiene la alarma y haga clic en para ver el nombre del host para el que se genera la alarma.
  2. Inicie sesión en el nodo donde se encuentra la instancia RangerAdmin como usuario omm. Ejecute el comando ps -ef|grep "proc_RangerAdmin" | grep -v grep | awk -F ' ' '{print $2}' para obtener el pid del proceso RangerAdmin y ejecute el comando netstat -anp|grep pid | grep LISTEN para comprobar si el proceso RangerAdmin escucha el puerto 21401 en el modo de seguridad y el puerto 21400 en el modo estándar.

    • En caso afirmativo, vaya a 4.
    • Si no, reinicie la instancia de RangerAdmin o el servicio Ranger defectuosos y vaya a 3.

  3. En la lista de alarmas, compruebe si la alarma "Estado anormal de RangerAdmin" está desactivada.

    • En caso afirmativo, no es necesario hacer nada más.
    • Si no, vaya a 4.

Recopilar información de fallas.

  1. En FusionInsight Manager, elija O&M > Log > Download.
  2. Expanda la lista desplegable Service y seleccione Ranger para el clúster de destino.
  3. Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 1 hora antes y después del tiempo de generación de alarma, respectivamente. A continuación, haga clic en Download.
  4. Póngase en contacto con y proporcione los registros recopilados.

Eliminación de alarmas

Después de rectificar el fallo que activa la alarma, la alarma se borra automáticamente.

Información relacionada

Ninguna