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Actualización más reciente 2023-11-20 GMT+08:00

ALM-44004 Las tareas en cola del grupo de recursos de Presto Coordinator superan el umbral

Descripción

Esta alarma se genera cuando el sistema detecta que el número de tareas de cola en un grupo de recursos excede el umbral. El sistema consulta el número de tareas de cola en un grupo de recursos a través de la interfaz JMX. Puede elegir Components > Presto > Service Configuration (cambiar Basic a All) > Presto > resource-groups para configurar un grupo de recursos. Puede elegir Components > Presto > Service Configuration (cambiar Basic a All) > Coordinator > Customize > resourceGroupAlarm para configurar el umbral de cada grupo de recursos.

Atributo

ID de alarma

Severidad de alarma

Borrar automáticamente

44004

Grave

Parámetros

Nombre

Significado

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Impacto en el sistema

Si el número de tareas de cola en un grupo de recursos excede el umbral, un gran número de tareas puede estar en el estado de cola. El tiempo de tarea de Presto supera el valor esperado. Cuando el número de tareas de cola en un grupo de recursos excede el número máximo (maxQueued) de tareas de cola en el grupo de recursos, no se pueden ejecutar nuevas tareas.

Causas posibles

La configuración del grupo de recursos es incorrecta o se envían demasiadas tareas en el grupo de recursos.

Procedimiento

  1. Seleccione Components > Presto > Service Configuration (cambiar Basic a All) > Presto > resource-groups para ajustar la configuración del grupo de recursos.
  2. Puede elegir Components > Presto > Service Configuration (cambiar Basic a All) > Coordinator > Customize > resourceGroupAlarm para modificar el umbral de cada grupo de recursos.
  3. Recopilar información de fallas.

    1. Inicie sesión en el nodo del clúster según el nombre del host en la información de error y consulte el número de tareas de cola según Resource Group en la información adicional del cliente de Presto.
    2. Inicie sesión en el nodo del clúster basándose en el nombre del host en la información de errores, vea el archivo /var/log/Bigdata/nodeagent/monitorlog/monitor.log y busque información del grupo de recursos para ver la información de recopilación de supervisión del grupo de recursos.
    3. Póngase en contacto con el personal de O&M y envíe los registros recopilados.

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Ninguna