ALM-44000 Servicio Presto no disponible
Descripción
El sistema comprueba el estado del servicio Presto cada 60 segundos. Esta alarma se genera cuando el sistema detecta que Presto no está disponible.
Esta alarma se borra cuando el servicio Presto se recupera.
Atributo
ID de alarma |
Severidad de alarma |
Borrar automáticamente |
---|---|---|
44000 |
Crítica |
Sí |
Parámetros
Nombre |
Significado |
---|---|
ServiceName |
Especifica el servicio para el que se genera la alarma. |
RoleName |
Especifica el rol para el que se genera la alarma. |
HostName |
Especifica el host para el que se genera la alarma. |
Impacto en el sistema
Presto no puede ejecutar consultas SQL.
Causas posibles
- El proceso de Coordinator o worker de Presto es defectuoso.
- Se interrumpe la comunicación de red entre las instancias del Presto coordinator y del worker.
Procedimiento
- Comprobar el estado de los procesos de coordinator y worker.
- Inicie sesión en FusionInsight Manager y elija Cluster > Services > Presto. En la página que se muestra, haga clic en la pestaña Instance. En la lista de instancias de Presto, compruebe si el estado de todas las instancias de coordinator o de worker es Unknown.
- En la parte superior de la lista de instancias de Presto, elija More > Restart Service para reiniciar los procesos de coordinator y worker.
- En la lista de alarmas, compruebe si ALM-44000 Servicio Presto no disponible está desactivado.
- Recopile información de fallas.
- En FusionInsight Manager, elija System >Export Log.
- Seleccione Presto para Service.
- Haga clic en en la esquina superior derecha.
Establezca Start Time y End Time para la recopilación de registros a 10 minutos antes y después del tiempo de generación de alarma, respectivamente. A continuación, haga clic en OK.
- Póngase en contacto con el personal de O&M y envíe los registros recopilados.
Eliminación de alarmas
Esta alarma se borra automáticamente después de rectificar la falla.