ALM-38000 Servicio Kafka no disponible
Descripción
El sistema comprueba el estado del servicio Kafka cada 30 segundos. Esta alarma se genera cuando el servicio Kafka no está disponible.
Esta alarma se borra cuando se recupera el servicio Kafka.
Atributo
ID de alarma |
Gravedad de la alarma |
Borrado automáticamente |
---|---|---|
38000 |
Crítica |
Sí |
Parámetros
Nombre |
Significado |
---|---|
Source |
Especifica el clúster para el que se genera la alarma. |
ServiceName |
Especifica el servicio para el que se genera la alarma. |
RoleName |
Especifica el rol para el que se genera la alarma. |
HostName |
Especifica el host para el que se genera la alarma. |
Impacto en el sistema
El clúster no puede proporcionar el servicio de Kafka y los usuarios no pueden realizar nuevas tareas de Kafka.
Causas posibles
- El servicio KrbServer es anormal.(Omita este paso si se utiliza el modo normal.)
- El servicio ZooKeeper es anormal o no responde.
- La instancia de Broker en el clúster de Kafka es anormal.
Procedimiento
Verificar el estado del servicio KrbServer. (Omita este paso si se usa el modo normal).
- En el portal del FusionInsight Manager, elija Cluster > Name of the desired cluster > Services > KrbServer.
- Compruebe si el estado de ejecución del servicio KrbServer es de tipo Normal.
- Rectifique la falla siguiendo los pasos indicados en el documento ALM-25500 Servicio KrbServer no disponible.
- Realice 2 de nuevo.
Verificar el estado del clúster de ZooKeeper.
- Compruebe si el estado de ejecución del servicio ZooKeeper es de tipo Normal.
- Si el servicio ZooKeeper se detiene, inícielo, si no, rectifique la falla siguiendo los pasos indicados en el documento ALM-13000 Servicio ZooKeeper no disponible.
- Realice 5 de nuevo.
Comprobar el estado de Broker.
- Seleccione Cluster > Name of the desired cluster > Services > Kafka > Instance para ir a la página de instancias de Kafka.
- Compruebe si todas las instancias de Roles se están ejecutando correctamente.
- Seleccione todas las instancias de Broker, elija More > Restart Instance y compruebe si las instancias se reinician correctamente.
- Elija Cluster > Name of the desired cluster > Services > Kafka para comprobar si el estado de ejecución es de tipo Normal.
- Espere 30 segundos y compruebe si la alarma está desactivada.
- De ser así, no se requiere ninguna acción adicional.
- Si no, vaya a 13.
Recopilación de información de error
- En el portal de FusionInsight Manager, seleccione O&M > Log > Download.
- Seleccione Kafka en el clúster requerido en la lista desplegable Service.
- Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 10 minutos antes y después del tiempo de generación de alarmas, respectivamente. A continuación, haga clic en Download.
- Póngase en contacto con el y envíe los registros recopilados.
Eliminación de alarmas
Después de rectificar la falla, el sistema borra automáticamente esta alarma.
Información relacionada
Ninguna