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Centro de ayuda> MapReduce Service> Guía del usuario> Referencia de alarma (aplicable a MRS 3.x)> ALM-29006 Número de conexiones de Impalad ODBC supera el umbral
Actualización más reciente 2023-11-20 GMT+08:00

ALM-29006 Número de conexiones de Impalad ODBC supera el umbral

Descripción

El sistema comprueba el número de conexiones de cliente al nodo Impalad cada 30 segundos. Esta alarma se genera cuando el número de conexiones de cliente excede el umbral personalizado (60 por defecto).

Esta alarma se borra automáticamente cuando el número de conexiones de cliente es menor que el umbral.

Atributo

ID de alarma

Severidad de alarma

Borrado automáticamente

29006

Grave

Parámetros

Nombre

Significado

Source

Especifica el clúster para el que se genera la alarma.

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Trigger Condition

Especifica el umbral para activar la alarma.

Impacto en el sistema

Las nuevas conexiones de cliente pueden estar bloqueadas o incluso fallar.

Causas posibles

El número de conexiones de cliente mantenidas por el servicio Impalad es demasiado grande o el umbral es demasiado pequeño.

Procedimiento

  1. En FusionInsight Manager, seleccione O&M > Alarm > Thresholds > Impala > Connections > Number of ODBC Connections to Impalad Process (Impalad) para comprobar el umbral.

  2. Compruebe el número de aplicaciones ODBC conectadas a Impalad y detenga las aplicaciones inactivas. Compruebe si la alarma se borra automáticamente.

    • En caso afirmativo, no es necesario hacer nada más.
    • Si no, vaya a 3 para cambiar el número de conexiones simultáneas soportadas por Impalad.

  3. En FusionInsight Manager, seleccione Cluster > Impala > Configurations > All Configurations > Impalad > Customization. Agregue el parámetro personalizado --fe_service_threads. El valor predeterminado de este parámetro es 64. Cambie el valor según sea necesario y haga clic en Save.

  4. Una vez completadas las tareas de consulta en todos los clientes, haga clic en la pestaña Instance. Seleccione todas las instancias de Impalad y reinícielas.

  5. Una vez finalizado el reinicio, se borra la alarma. Ejecute la aplicación que utiliza ODBC para conectarse a Impalad de nuevo.

Eliminación de alarmas

Después de rectificar el fallo que activa la alarma, la alarma se borra automáticamente.

Información relacionada

Ninguna