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Actualización más reciente 2023-11-20 GMT+08:00

ALM-29000 Servicio Impala no disponible

Descripción

El módulo de alarma comprueba el estado del servicio Impala cada 30 segundos. Esta alarma se genera si el servicio Impala es anormal.

Esta alarma se borra después de que el servicio de Impala se recupere.

Atributo

ID de alarma

Severidad de alarma

Borrado automáticamente

29000

Crítica

Parámetros

Nombre

Significado

Source

Especifica el clúster para el que se genera la alarma.

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Impacto en el sistema

Cuando el servicio Impala es anormal, no puede realizar operaciones de clúster en Impala a través de FusionInsight Manager. Las funciones del servicio Impala no están disponibles.

Causas posibles

  • El servicio Hive es anormal.
  • El servicio KrbServer es anormal.
  • El proceso de Impala es anormal.

Procedimiento

Comprobar si los servicios de los que depende Impala son normales.

  1. En FusionInsight Manager, seleccione Cluster > Services para comprobar si Hive y KrbServer están detenidos.

    • En caso afirmativo, inicie los servicios parados y vaya a 2.
    • Si no, vaya a 3.

  2. En FusionInsight Manager, seleccione O&M > Alarm > Alarms. En la lista de alarmas, compruebe si la alarma Serivcio Impala no disponible está desactivada.

    • En caso afirmativo, no es necesario hacer nada más.
    • Si no, vaya a 3.

  3. En FusionInsight Manager, seleccione O&M > Alarm > Alarms. En la lista de alarmas, compruebe si ALM-16004 Servicio Hive no está disponible y ALM-25500 Servicio KrbServer no está disponible.

    • En caso afirmativo, vaya a 4.
    • Si no, vaya a 5.

  4. Rectifique la falla siguiendo el procedimiento de manejo de ALM-16004 Servicio Hive no disponible o ALM-25500 Servicio KrbServer no disponible. Luego, verifique si la alarma se rectificó.

    • En caso afirmativo, no es necesario hacer nada más.
    • Si no, vaya a 5.

Comprobar si el proceso Impala es normal.

  1. En FusionInsight Manager, seleccione O&M > Alarm > Alarms. Compruebe si existe ALM-12007 Falla de proceso en la lista de alarma.

    • En caso afirmativo, vaya a 6.
    • Si no, vaya a 7.

  2. Rectifique la falla haciendo referencia al método de manejo de ALM-12007 Falla de proceso, y a continuación, compruebe si la alarma está borrada.

    • En caso afirmativo, no es necesario hacer nada más.
    • Si no, vaya a 7.

Recopilar información de fallas.

  1. En FusionInsight Manager, elija O&M > Log > Download.
  2. Expanda la lista desplegable Service y seleccione Impala para el clúster de destino.
  3. Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 1 hora antes y después del tiempo de generación de alarma, respectivamente. A continuación, haga clic en Download.
  4. Póngase en contacto con y proporcione los registros recopilados.

Eliminación de alarmas

Después de rectificar el fallo que activa la alarma, la alarma se borra automáticamente.

Información relacionada

Ninguna