Estos contenidos se han traducido de forma automática para su comodidad, pero Huawei Cloud no garantiza la exactitud de estos. Para consultar los contenidos originales, acceda a la versión en inglés.
Centro de ayuda> MapReduce Service> Guía del usuario> Referencia de alarma (aplicable a MRS 3.x)> ALM-16046 Se modifica el permiso de almacén de datos de Hive
Actualización más reciente 2023-11-20 GMT+08:00

ALM-16046 Se modifica el permiso de almacén de datos de Hive

Descripción

El sistema comprueba el permiso del almacén de datos de Hive cada 60 segundos. Esta alarma se genera si se modifica el permiso.

Atributo

ID de alarma

Gravedad de la alarma

Borrar automáticamente

16046

Crítica

Parámetros

Nombre

Significado

Source

Especifica el clúster para el que se genera la alarma.

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Impacto en el sistema

Si se modifica el permiso del almacén de datos predeterminado de Hive, se modifica el permiso para que los usuarios o grupos de usuarios creen bases de datos o tablas en el almacén de datos predeterminado.

Causas posibles

Hive comprueba periódicamente el estado del almacén de datos predeterminado y encuentra que se ha cambiado el permiso del almacén de datos predeterminado.

Procedimiento

Comprobar el permiso de almacén de datos predeterminado de Hive.

  1. Inicie sesión en el nodo donde se encuentra el cliente como usuario root.
  1. Ejecute el siguiente comando para ir al directorio de instalación del cliente HDFS:

    cd Client installation directory

    source bigdata_env

    kinit User who has the supergroup permission (Omita este paso para un clúster común.)

  2. Ejecute el siguiente comando para restaurar el permiso de almacén de datos predeterminado:

    • Modo de seguridad: hdfs dfs -chmod 770 hdfs://hacluster/user/hive/warehouse
    • Modo sin seguridad: hdfs dfs -chmod 777 hdfs://hacluster/user/hive/warehouse

  3. Verifique si la alarma se ha borrado.

    • Si lo es, no se requiere ninguna otra acción.
    • Si no es así, vaya a 5.

Recopilar información de fallas.

  1. Recopilar información relacionada en el directorio hdfs://hacluster/user/hive/warehouse en el fondo del cliente.
  2. Póngase en contacto con el y envíe los registros recopilados.

Eliminación de alarmas

Después de rectificar la falla, el sistema borra automáticamente esta alarma.

Información relacionada

Ninguna