Estos contenidos se han traducido de forma automática para su comodidad, pero Huawei Cloud no garantiza la exactitud de estos. Para consultar los contenidos originales, acceda a la versión en inglés.
Actualización más reciente 2023-11-20 GMT+08:00

ALM-16045 Se elimina el almacén de datos de Hive

Descripción

El sistema comprueba el almacén de datos de Hive cada 60 segundos. Esta alarma se genera cuando se elimina el almacén de datos de Hive.

Atributo

ID de alarma

Gravedad de la alarma

Borrar automáticamente

16045

Crítica

Parámetros

Nombre

Significado

Source

Especifica el clúster para el que se genera la alarma.

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Impacto en el sistema

Se elimina el almacén de datos de Hive predeterminado. Como resultado, la creación de bases de datos o tablas en el almacén de datos predeterminado falla y los servicios se ven afectados.

Causas posibles

Hive comprueba periódicamente el estado del almacén de datos predeterminado y encuentra que se elimina el almacén de datos predeterminado.

Procedimiento

Comprobar el almacén de datos predeterminado de Hive.

  1. Inicie sesión en el nodo donde se encuentra el cliente como usuario root.
  1. Ejecute el siguiente comando para comprobar si el directorio warehouse existe en hdfs://hacluster/user/<username>/.Trash/Current/.

    hdfs dfs -ls hdfs://hacluster/user/<username>/.Trash/Current/

    Por ejemplo, si existe user/hive/warehouse:
    host01 # hdfs dfs -ls hdfs://hacluster/user/test/.Trash/Current/
    Found 1 items
    drwx------   - test hadoop          0 2019-06-17 19:53 hdfs://hacluster/user/test/.Trash/Current/user
    • En caso afirmativo, vaya a 3.
    • Si no, vaya a 5.

  1. De forma predeterminada, existe un mecanismo de recuperación automática para el almacén de datos. Puede esperar 5 ~10s para comprobar si se restaura el almacén de datos predeterminado. Si el almacén de datos no se recupera, ejecute manualmente el siguiente comando para restaurar el almacén de datos.

    hdfs dfs -mv hdfs://hacluster/user/<username>/.Trash/Current/user/hive/warehouse /user/hive/warehouse

  2. Verifique si la alarma se ha borrado.

    • De ser así, no se requiere ninguna acción adicional.
    • Si no, vaya a 5.

Recopilar información de fallas.

  1. Recopilar información relacionada en el directorio .Trash/Current/ en el fondo del cliente.
  2. Póngase en contacto con el y envíe los registros recopilados.

Eliminación de alarmas

Después de rectificar la falla, el sistema borra automáticamente esta alarma.

Información relacionada

Ninguna