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Actualización más reciente 2023-11-20 GMT+08:00

ALM-16000 Porcentaje de sesiones conectadas al HiveServer al número máximo permitido supera el umbral

Descripción

El sistema detecta el porcentaje de sesiones conectadas al HiveServer hasta el número máximo de sesiones permitidas cada 30 segundos. Este indicador se puede ver en el nombre del Cluster > Name of the desired cluster > Services > Hive > Instance > HiveServer instance. Esta alarma se genera cuando el porcentaje excede el valor predeterminado 90%.

Para cambiar el umbral, elija O&M > Alarm > Thresholds > Name of the desired cluster > Hive > Percentage of Sessions Connected to the HiveServer to Maximum Number of Sessions Allowed by the HiveServer.

Cuando el Trigger Count es 1, esta alarma se borra cuando el porcentaje es menor o igual al umbral. Cuando el Trigger Count es mayor que 1, esta alarma se borra cuando el porcentaje es menor o igual al 90% del umbral.

Atributo

ID de alarma

Gravedad de la alarma

Borrado automáticamente

16000

Leves

Parámetros

Nombre

Significado

Source

Especifica el clúster para el que se genera la alarma.

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Trigger Condition

Especifica el umbral que activa la alarma. Si el valor del indicador actual excede este umbral, se genera la alarma.

Impacto en el sistema

Si se genera una alarma de conexión, hay demasiadas sesiones conectadas a Hive y las nuevas conexiones no están disponibles.

Causas posibles

Hay demasiados clientes conectados a HiveServer.

Procedimiento

Aumentar el número máximo de conexiones a Hive.

  1. En el portal del FusionInsight Manager, elija Cluster > Name of the desired cluster > Services > Hive > Configurations >All Configurations.
  2. Busque hive.server.session.control.maxconnections y aumente el valor de este parámetro. Si el valor de este parámetro es A, el umbral es B y el número de sesiones conectadas al HiveServer es C, ajuste el valor de este parámetro de acuerdo con A x B > C. Para ver el número de sesiones conectadas al HiveServer, compruebe el valor de Statistics for Sessions of the HiveServer en la página de supervisión de Hive.
  3. Verifique si la alarma se ha borrado.

    • De ser así, no se requiere ninguna acción adicional.
    • Si no, vaya a 4.

Recopilar información de fallas.

  1. En el portal del FusionInsight Manager, elija O&M > Log > Download.
  2. Seleccione Hive en el clúster requerido en el Service.
  3. Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 10 minutos antes y después del tiempo de generación de alarmas, respectivamente. A continuación, haga clic en Download.
  4. Póngase en contacto con el y envíe los registros recopilados.

Eliminación de alarmas

Después de rectificar la falla, el sistema borra automáticamente esta alarma.

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Ninguna