ALM-14030 HDFS permite la escritura de datos de una sola réplica
Descripción
Esta alarma se genera cuando dfs.single.replication.enable se establece en true, indicando que HDFS está configurado para permitir la escritura de datos de réplica única.
Esta alarma se borra cuando esta función está deshabilitada en HDFS.
Atributo
ID de alarma |
Severidad de alarma |
Borrar automáticamente |
---|---|---|
14030 |
Advertencia |
Sí |
Parámetros
Nombre |
Significado |
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Source |
Especifica el clúster para el que se genera la alarma. |
ServiceName |
Especifica el servicio para el que se genera la alarma. |
RoleName |
Especifica el rol para el que se genera la alarma. |
Impacto en el sistema
Si esta configuración está habilitada en el servidor y el número de réplicas HDFS configuradas en el cliente es 1, los datos de una sola réplica se pueden escribir en HDFS. Los datos de una única réplica pueden perderse. Por lo tanto, el sistema no permite la escritura de datos de réplica única de forma predeterminada. Si un servicio requiere escritura de datos de réplica única en un directorio, modifique el elemento de configuración de HDFS dfs.single.replication.exclude.pattern.
Causas posibles
El elemento de configuración HDFS dfs.single.replication.enable se establece en true.
Procedimiento
- Inicie sesión en FusionInsight Manager y elija Cluster > Services > HDFS. En la página que se muestra, haga clic en la pestaña Configurations y luego en la subpestaña All Configurations.
- Busque dfs.single.replication.enable en el cuadro de búsqueda, cambie el valor del elemento de configuración a false y haga clic en Save.
- Espere unos 10 minutos y compruebe si la alarma está desactivada.
- En caso afirmativo, no es necesario hacer nada más.
- Si no, vaya a 4.
Recopilar información de fallas.
- En FusionInsight Manager, seleccione O&M. En el panel de navegación de la izquierda, elija Log > Download.
- Expanda la lista desplegable junto al campo Service. En el cuadro de diálogo Services que se muestra, seleccione HDFS para el clúster de destino.
- Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 10 minutos antes y después del tiempo de generación de alarmas, respectivamente. A continuación, haga clic en Download.
- Póngase en contacto con y proporcione los registros recopilados.
Eliminación de alarmas
Esta alarma se borra automáticamente después de rectificar la falla.
Información relacionada
Ninguna