ALM-14024 El uso del espacio del tenant supera el umbral
Descripción
El sistema comprueba el uso de espacio (espacio usado de cada directorio/espacio asignado a cada directorio) de cada directorio asociado con un tenant cada hora y compara el uso de espacio de cada directorio con el umbral establecido para el directorio. Esta alarma se genera cuando el uso de espacio excede el umbral.
Esta alarma se borra cuando el uso de espacio es menor o igual que el umbral.
Atributo
ID de alarma |
Gravedad de la alarma |
Borrado automáticamente |
---|---|---|
14024 |
Leves |
Sí |
Parámetros
Nombre |
Significado |
---|---|
Source |
Especifica el clúster para el que se genera la alarma. |
ServiceName |
Especifica el servicio para el que se genera la alarma. |
RoleName |
Especifica el rol para el que se genera la alarma. |
HostName |
Especifica el host para el que se genera la alarma. |
TenantName |
Especifica el inquilino para el que se genera la alarma. |
DirectoryName |
Especifica el directorio para el que se genera la alarma. |
Trigger condition |
Especifica el umbral para activar la alarma. |
Impacto en el sistema
Esta alarma se genera si el uso de espacio del directorio del tenant excede el umbral personalizado. La escritura de archivos en el directorio no se ve afectada. Si el espacio utilizado excede el espacio de almacenamiento máximo asignado al directorio, el HDFS no puede escribir datos en el directorio.
Causas posibles
- El umbral de alarma está configurado incorrectamente.
- El espacio asignado al tenant es inadecuado.
Procedimiento
Comprobar si el umbral de alarma es adecuado.
- Vea la información de ubicación de la alarma para obtener el nombre del tenant y el directorio del tenant para el que se genera la alarma.
- En el portal del FusionInsight Manager, elija la página Tenant Resources y seleccione el tenant para el que se genera la alarma y haga clic en Resources. Compruebe si el umbral de espacio de almacenamiento configurado para el directorio de tenant para el que se genera la alarma es adecuado. (El valor predeterminado 90% es un valor apropiado. Puede configurarlo en función de los requisitos del sitio.)
- En la página Resources, haga clic en Modify para modificar o eliminar el umbral de espacio de almacenamiento.
- Aproximadamente un minuto más tarde, compruebe si la alarma está desactivada.
- De ser así, no se requiere ninguna acción adicional.
- Si no, vaya a 5.
Comprobar si el espacio asignado al tenant es adecuado.
- En el portal del FusionInsight Manager, elija la página Tenant Resources y seleccione el tenant para el que se genera la alarma y haga clic en Resources. Compruebe si la cuota de espacio de almacenamiento del directorio de tenants para el que se genera la alarma es adecuada basándose en el estado de servicio real del directorio de tenant.
- En la página Resources, haga clic en Modify para modificar la cuota de espacio de almacenamiento.
- Aproximadamente un minuto más tarde, compruebe si la alarma está desactivada.
- De ser así, no se requiere ninguna acción adicional.
- Si no, vaya a 8.
Recopilar información de fallas.
- En el portal del FusionInsight Manager, seleccione O&M > Log > Download.
- Seleccione HDFS en el clúster requerido y NodeAgent en Manager en el Service.
- Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 20 minutos antes y después del tiempo de generación de alarmas, respectivamente. A continuación, haga clic en Download.
- Póngase en contacto con el y envíe los registros recopilados.
Eliminación de alarmas
Después de rectificar la falla, el sistema borra automáticamente esta alarma.
Información relacionada
Ninguna