ALM-13005 No se pudo establecer la cuota de los principales directorios de los componentes de ZooKeeper
Descripción
El sistema establece cuotas para cada directorio de nivel superior ZooKeeper en el elemento de configuración y componentes customized.quota cada 5 horas. Esta alarma se genera cuando el sistema no puede establecer la cuota para un directorio.
Esta alarma se borra cuando la configuración se realiza correctamente después de una falla.
Atributo
ID de alarma |
Gravedad de la alarma |
Borrado automáticamente |
---|---|---|
13005 |
Leves |
Sí |
Parámetros
Nombre |
Significado |
---|---|
Source |
Especifica el clúster para el que se genera la alarma. |
ServiceName |
Especifica el nombre del servicio para el que se genera la alarma. |
ServiceDirectory |
Especifica el directorio para el que se genera la alarma. |
Trigger Condition |
Especifica la causa de la alarma. |
Impacto en el sistema
Los componentes pueden escribir una gran cantidad de datos en el directorio de nivel superior de ZooKeeper. Como resultado, el servicio ZooKeeper no está disponible.
Causas posibles
La cuota para el directorio de alarma es inapropiada.
Procedimiento
Comprobar si la cuota para el directorio de alarmas es adecuada.
- Inicie sesión en FusionInsight Manager y elija Cluster > Name of the desired cluster > Services > ZooKeeper. En la página mostrada, elija Configurations > All Configurations > Quota. Compruebe si el directorio para el que se informa la alarma y su cuota existen en el elemento de configuración customized.quota.
- Compruebe si el directorio de alarmas para el que se reporta la alarma se encuentra en la siguiente lista de alarmas.
Tabla 1 Directorio de alarmas de componentes Componente
Directorio de alarmas
Hbase
/hbase
Hive
/beelinesql
Yarn
/rmstore
Storm
/stormroot
Streaming
/storm
Kafka
/kafka
- Vea el componente del directorio de alarma en la tabla, abra la página de servicio correspondiente y elija Configurations > All Configurations. En la página mostrada, busque zk.quota en la esquina superior derecha. El resultado de la búsqueda es la cuota del directorio de alarma.
- Compruebe si la cuota del directorio de alarmas para el que se informa es apropiada. La cuota debe ser mayor o igual que el valor real, que se puede obtener en Trigger Condition.
- Modifique el valor services.quota como se le solicite y guarde la configuración.
- Después del tiempo especificado por service.quotas.auto.check.cron.expression, compruebe si la alarma está desactivada.
- Si lo es, no se requiere ninguna otra acción.
- Si no, vaya a 7.
Recopilar información de fallas.
- En el portal del FusionInsight Manager, elija O&M > Log > Download.
- Seleccione ZooKeeper en el clúster requerido en el Service.
- Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 10 minutos antes y después del tiempo de generación de alarmas, respectivamente. A continuación, haga clic en Download.
- Póngase en contacto con el y envíe los registros recopilados.
Eliminación de alarmas
Después de rectificar la falla, el sistema borra automáticamente esta alarma.
Información relacionada
Ninguna