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Centro de ayuda> MapReduce Service> Guía del usuario> Referencia de alarma (aplicable a MRS 3.x)> ALM-12190 Número de conexiones Knox supera el umbral
Actualización más reciente 2023-11-20 GMT+08:00

ALM-12190 Número de conexiones Knox supera el umbral

Descripción

El sistema comprueba periódicamente el número de conexiones a todas las topologías Knox. Esta alarma se genera cuando el número de conexiones a una topología supera el umbral (90% por defecto). Esta alarma se borra automáticamente cuando el número de conexiones a una topología cae por debajo del umbral.

Esta alarma se aplica a clústeres de MRS 3.1.0 o posterior.

Atributo

ID de alarma

Severidad de alarma

Borrar automáticamente

12190

Grave

Parámetros

Nombre

Significado

Source

Especifica el clúster o sistema para el que se genera la alarma.

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Topology

Especifica la topología de Knox para la que se genera la alarma.

Impacto en el sistema

La topología puede alcanzar el límite superior de conexiones y no reenviar solicitudes, afectando negativamente a las funciones de MRS.

Causas posibles

Hue o Manager se usa con demasiada frecuencia, pero el número máximo predeterminado de conexiones Knox es pequeño.

Procedimiento

  1. Inicie sesión en los nodos OMS activos y en espera como usuario root, respectivamente.
  2. Agregue la siguiente configuración al archivo gateway-site.xml en los nodos de OMS activo y en espera para aumentar el número de grupos de subprocesos:

    vi /opt/knox/conf/gateway-site.xml

    <property>
    <name>gateway.httpclient.maxConnections</name>
    <value>64</value>
    </property>

  3. Inicie sesión en el nodo OMS activo como usuario omm y ejecute el siguiente comando para reiniciar el proceso Knox:

    sh /opt/knox/bin/restart-knox.sh

  4. Después de 5 minutos, compruebe si la alarma está borrada.

    • En caso afirmativo, no es necesario hacer nada más.
    • Si no, vaya a 5.

  5. Póngase en contacto con para rectificar la falla.

Eliminación de alarmas

Esta alarma se borra automáticamente después de rectificar la falla.

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Ninguna