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Actualización más reciente 2023-11-20 GMT+08:00

ALM-12075 El recurso de PMS es anormal

Descripción

HA comprueba los recursos pms de Manager cada 55 segundos. Esta alarma se genera cuando HA detecta que los recursos pms son anormales durante tres veces consecutivas.

Esta alarma se borra cuando el recurso PMS es normal.

Resource Type de PMS es de Single-active. Activo/en espera se activará en caso de excepciones de recursos. Cuando se genera esta alarma, se completa la conmutación activa/en espera y se han habilitado nuevos recursos de PMS en el nuevo FusionInsight Manager. En este caso, esta alarma se borra. Esta alarma se utiliza para notificar a los usuarios de la causa de la conmutación activa/en espera.

Atributo

ID de alarma

Gravedad de la alarma

Borrar automáticamente

12075

Importante

Parámetros

Nombre

Significado

Source

Especifica el clúster o sistema para el que se genera la alarma.

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Impacto en el sistema

  • Se produce la conmutación del FusionInsight Manager activo/en espera.
  • El proceso PMS se reinicia repetidamente, haciendo que la información de monitorización sea anormal.

Causas posibles

El proceso de PMS es anormal.

Procedimiento

Comprobar si el proceso PMS es anormal.

  1. En la lista de alarmas del FusionInsight Manager, busque la fila que contiene la alarma y vea el nombre del host para el que se genera la alarma.
  2. Inicie sesión en el host para el que se genera la alarma como usuario root.
  3. Ejecute el comando su -omm y, a continuación, el comando sh ${BIGDATA_HOME}/om-server/OMS/workspace0/ha/module/hacom/script/status_ha.sh para comprobar si el estado de los recursos PMS gestionados por el HA es normal. En el sistema de nodo único, el recurso PMS está en el estado normal. En el sistema de nodo doble, el recurso PMS está en el estado normal en el nodo activo y en el estado detenido en el nodo de espera.

    • Si lo es, vaya a 6.
    • Si no es así, vaya a 4.

  4. Ejecute los comandos vi $BIGDATA_LOG_HOME/omm/oms/pms/pms.log y vi $BIGDATA_LOG_HOME/omm/oms/pms/scriptlog/pms_ha.log para ver los registros de recursos de PMS, compruebe si existe la palabra clave ERROR. Analice los registros para localizar y rectificar la falla.
  5. Cinco minutos más tarde, compruebe si esta alarma está desactivada.

    • Si lo es, no se requiere ninguna otra acción.
    • Si no es así, vaya a 6.

Recopilar información de fallas.

  1. En FusionInsight Manager, seleccione O&M> Log > Download.
  2. Seleccione Controller y OmmServer para Service y haga clic en OK.
  3. Haga clic en en la esquina superior derecha. En el cuadro de diálogo que aparece, establezca Start Date y End Date en 1 hora antes y después del tiempo de generación de alarmas, respectivamente, y haga clic en OK. A continuación, haga clic en Download.
  4. Póngase en contacto con el y envíe la información de registro recopilada.

Eliminación de alarmas

Esta alarma se borrará automáticamente después de que se corrija la falla.

Información relacionada

Ninguna