ALM-12064 Conflictos de rango de puertos aleatorios del host con el puerto utilizado del clúster
Descripción de la alarma
El sistema comprueba si el rango de puertos aleatorios del host entra en conflicto con el rango de puertos utilizado por el sistema de clúster cada hora. La alarma se genera si entran en conflicto. La alarma se borra automáticamente cuando el rango de puertos aleatorios del host se cambia al rango normal.
Atributo
ID de alarma |
Gravedad de la alarma |
Borrar automáticamente |
---|---|---|
12064 |
Importante |
Sí |
Parámetros
Parámetro |
Descripción |
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Source |
Especifica el sistema o clúster para el que se ha generado el mismo. |
ServiceName |
Especifica el nombre del servicio para el que se genera la alarma. |
RoleName |
Especifica el rol para el que se genera la alarma. |
HostName |
Especifica el host para el que se genera la alarma. |
Impacto en el sistema
El puerto predeterminado del sistema de clúster está ocupado. Como resultado, algunos procesos no pueden iniciarse.
Causas posibles
Se modifica la configuración de rango de puertos aleatorios.
Procedimiento
Verifique el rango de puertos aleatorios del sistema.
- En la lista de alarmas del FusionInsight Manager, localice la fila que contiene la alarma y vea la dirección IP del host para el que se genera la alarma.
- Inicie sesión en el host donde se genera la alarma como usuario root.
- Ejecute el comando cat /proc/sys/net/ipv4/ip_local_port_range para obtener el rango de puertos aleatorios del host y verifique si el valor mínimo es menor que 32768.
- Ejecute el comando vim /etc/sysctl.conf para cambiar el valor de net.ipv4.ip_local_port_range a 32768 61000. Si este parámetro no existe, agregue la siguiente configuración net.ipv4.ip_local_port_range = 32768 61000.
- Ejecute el comando sysctl -p /etc/sysctl.conf para que la modificación surta efecto.
- Una hora más tarde, compruebe si la alarma está desactivada.
- Si lo es, no se requiere ninguna otra acción.
- Si no es así, vaya a 7.
Recopilar información de fallas.
- En FusionInsight Manager, elija O&M > Log > Download.
- Seleccione NodeAgent para Service y haga clic en OK.
- Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 10 minutos antes y después del tiempo de generación de alarmas, respectivamente. A continuación, haga clic en Download.
- Póngase en contacto con el y envíe la información de registro recopilada.
Eliminación de alarmas
Después de rectificar la falla, el sistema borra automáticamente esta alarma.
Información relacionada
Ninguna