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Centro de ayuda> MapReduce Service> Guía del usuario> Referencia de alarma (aplicable a MRS 3.x)> ALM-12064 Conflictos de rango de puertos aleatorios del host con el puerto utilizado del clúster
Actualización más reciente 2023-11-20 GMT+08:00

ALM-12064 Conflictos de rango de puertos aleatorios del host con el puerto utilizado del clúster

Descripción de la alarma

El sistema comprueba si el rango de puertos aleatorios del host entra en conflicto con el rango de puertos utilizado por el sistema de clúster cada hora. La alarma se genera si entran en conflicto. La alarma se borra automáticamente cuando el rango de puertos aleatorios del host se cambia al rango normal.

Atributo

ID de alarma

Gravedad de la alarma

Borrar automáticamente

12064

Importante

Parámetros

Parámetro

Descripción

Source

Especifica el sistema o clúster para el que se ha generado el mismo.

ServiceName

Especifica el nombre del servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

Impacto en el sistema

El puerto predeterminado del sistema de clúster está ocupado. Como resultado, algunos procesos no pueden iniciarse.

Causas posibles

Se modifica la configuración de rango de puertos aleatorios.

Procedimiento

Verifique el rango de puertos aleatorios del sistema.

  1. En la lista de alarmas del FusionInsight Manager, localice la fila que contiene la alarma y vea la dirección IP del host para el que se genera la alarma.
  2. Inicie sesión en el host donde se genera la alarma como usuario root.
  3. Ejecute el comando cat /proc/sys/net/ipv4/ip_local_port_range para obtener el rango de puertos aleatorios del host y verifique si el valor mínimo es menor que 32768.

    • Si lo es, vaya a 4.
    • Si no lo es, vaya a 7.

  4. Ejecute el comando vim /etc/sysctl.conf para cambiar el valor de net.ipv4.ip_local_port_range a 32768 61000. Si este parámetro no existe, agregue la siguiente configuración net.ipv4.ip_local_port_range = 32768 61000.
  5. Ejecute el comando sysctl -p /etc/sysctl.conf para que la modificación surta efecto.
  6. Una hora más tarde, compruebe si la alarma está desactivada.

    • Si lo es, no se requiere ninguna otra acción.
    • Si no es así, vaya a 7.

Recopilar información de fallas.

  1. En FusionInsight Manager, elija O&M > Log > Download.
  2. Seleccione NodeAgent para Service y haga clic en OK.
  3. Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 10 minutos antes y después del tiempo de generación de alarmas, respectivamente. A continuación, haga clic en Download.
  4. Póngase en contacto con el y envíe la información de registro recopilada.

Eliminación de alarmas

Después de rectificar la falla, el sistema borra automáticamente esta alarma.

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Ninguna