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Centro de ayuda> MapReduce Service> Guía del usuario> Referencia de alarma (aplicable a MRS 3.x)> ALM-12035 Estado de datos desconocido después de un error de tarea de recuperación
Actualización más reciente 2023-11-20 GMT+08:00

ALM-12035 Estado de datos desconocido después de un error de tarea de recuperación

Descripción

Después de que la tarea de recuperación falla, el sistema se revierte automáticamente cada 60 minutos. Si la reversión falla, los datos pueden perderse. Si esto ocurre, se informa de una alarma. Esta alarma se borra cuando se ejecuta correctamente la siguiente tarea de recuperación.

Atributo

ID de alarma

Gravedad de la alarma

Borrar automáticamente

12035

Crítica

Parámetros

Nombre

Significado

Source

Especifica el clúster o sistema para el que se genera la alarma.

ServiceName

Especifica el servicio para el que se genera la alarma.

RoleName

Especifica el rol para el que se genera la alarma.

HostName

Especifica el host para el que se genera la alarma.

TaskName

Especifica la tarea.

Impacto en el sistema

Una vez que la tarea de recuperación falla, el sistema se revierte automáticamente. Si la reversión falla, los datos pueden perderse o el estado de los datos puede ser desconocido, lo que puede afectar a los servicios.

Causas posibles

La causa de la alarma depende de los detalles de la tarea. Manejar la alarma de acuerdo con los registros y detalles de alarma.

Procedimiento

Recopilar información de fallas.

  1. En el FusionInsight Manager, elija Cluster > Name of the desired cluster > Services y compruebe si el estado de ejecución del componente cumple los requisitos. (El OMS y DBService deben estar en el estado normal y los demás componentes deben estar detenidos.)

    • En caso afirmativo, vaya a 9.
    • Si no, vaya a 2.

  2. Restaure el estado del componente según sea necesario e inicie de nuevo la tarea de recuperación.
  3. Inicie sesión en el portal del FusionInsight Manager y haga clic en O&M > Alarm > Alarms.
  4. En la lista de alarmas, haga clic en en la fila donde se encuentra la alarma para obtener TaskName de Location.
  5. Elija O&M > Backup and Restoration > Restoration Management.
  6. Busque la tarea de restauración por Task Name y vea los detalles de la tarea.
  7. Vuelva a realizar la tarea de recuperación y compruebe si la ejecución de la tarea de recuperación se realiza correctamente.

    • En caso afirmativo, vaya a 8.
    • Si no, vaya a 9.

  8. Después de 2 minutos, compruebe si la alarma está borrada.

    • De ser así, no se requiere ninguna acción adicional.
    • Si no, vaya a 9.

Recopilar información de fallas.

  1. En el portal del FusionInsight Manager, elija O&M > Log > Download.
  2. Seleccione Controller en el Service y haga clic en OK.
  3. Haga clic en en la esquina superior derecha y establezca Start Date y End Date para la recopilación de registros en 10 minutos antes y después del tiempo de generación de alarmas, respectivamente. A continuación, haga clic en Download.
  4. Póngase en contacto con el y envíe la información de registro recopilada.

Eliminación de alarmas

Después de rectificar la falla, el sistema borra automáticamente esta alarma.

Información relacionada

Ninguna