Help Center> MapReduce Service> Troubleshooting> Using Storm> Internal Server Error Is Displayed When the User Queries Information on the Storm UI
Updated on 2023-11-30 GMT+08:00

Internal Server Error Is Displayed When the User Queries Information on the Storm UI

Symptom

An MRS cluster is installed, and ZooKeeper and Storm are installed in the cluster.

The following information is displayed when a user views information from the Storm status page on MRS Manager:

Internal Server Error
org.apache.thrift7.transport.TTransportException: Frame size (306030) larger than max length (1048576)!

Possible Causes

  • Nimbus of Storm is abnormal.
  • Storm cluster information exceeds the default Thrift transmission size.

Cause Analysis

  1. Check the Storm service status and monitoring metrics:
    • MRS Manager: Log in to MRS Manager and choose Services > Storm. Check the Storm status. The status is Good, and the monitoring metrics are correctly displayed.
    • FusionInsight Manager: Log in to FusionInsight Manager and choose Cluster > Services > Storm. Check the Storm status. The status is Good, and the monitoring metrics are correctly displayed.
  2. Click the Instance tab and check the status of the Nimbus instance. The status is normal.
  1. Check the Thrift configuration of the Storm cluster. It is found that nimbus.thrift.max_buffer_size is set to 1048576 (1 MB).
  2. The preceding configuration is the same as that in the exception information, indicating that the buffer size of Thrift is less than that required by the cluster information.

Procedure

Adjust the Thrift buffer size of the Storm cluster.

  1. Access the Storm parameter configuration page.

    • MRS Manager: Log in to MRS Manager, choose Services > Storm > Service Configuration, and select All from the Type drop-down list.
    • Operation on FusionInsight Manager: Log in to FusionInsight Manager and choose Cluster > Services > Yarn > Configurations > All Configurations.

  2. Change the value of nimbus.thrift.max_buffer_size to 10485760 (10 MB).
  3. Click Save Configuration, select Restart the affected services or instances, and click OK.