Updated on 2024-11-30 GMT+08:00

Incremental Phase Error: without PK execute failed

Scenarios

During an incremental migration or synchronization, an error is reported, and the log information is as follows: service INCREMENT failed, cause by: record tid: %s,seqno: %s without PK execute failed in table %s

Possible Causes

A conflict occurs during data synchronization for tables that do not have primary keys.

Solution

  1. Check whether the task is normal.

    • If the task is normal, this error is recorded in the log and no further action is required.
    • If the task is abnormal, go to 2.

  2. In the upper right corner of the console, choose Service Tickets > Create Service Ticket and contact customer service.