Updated on 2024-11-29 GMT+08:00

ALM-51201 LakeSearch Unavailable

Alarm Description

The system checks the LakeSearch service availability every 60 seconds. This alarm is generated when the system detects that the LakeSearch service is unavailable. The alarm is cleared when the LakeSearch service recovers.

Alarm Attributes

Alarm ID

Alarm Severity

Alarm Type

Service Type

Auto Cleared

51201

Critical

Error handling

LakeSearch

Yes

Alarm Parameters

Type

Parameter

Description

Location Information

Source

Specifies the cluster or system for which the alarm was generated.

ServiceName

Specifies the service for which the alarm was generated.

RoleName

Specifies the role for which the alarm was generated.

HostName

Specifies the host for which the alarm was generated.

Impact on the System

LakeSearch cannot provide services for external systems.

Possible Causes

The component on which LakeSearch depends is unavailable.

Handling Procedure

Check the running status of DBService, KrbServer, HBase, and Elasticsearch on which LakeSearch depends.

  1. Log in to FusionInsight Manager and choose Cluster > Services.
  2. Check whether Running Status of DBService, KrbServer, HBase, and Elasticsearch is Normal.

    • If yes, go to 6.
    • If no, go to 3.

  3. Click the name of a component whose Running Status is not Normal.
  4. In the Instances tab, select the faulty instance, choose More > Restart Instance, and check whether the instance can be started successfully.

    • If yes, go to 5.
    • If no, go to 6.

  5. Wait for one minute and check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 6.

Collect fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. Select LakeSearch for Service and click OK.
  3. In the Hosts area, select the host where the role is located.
  4. Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 1 hour ahead of and after the alarm generation time, respectively. Then, click Download.
  5. Contact O&M personnel and provide the collected logs.

Alarm Clearance

This alarm is automatically cleared after the fault is rectified.

Related Information

None