Help Center/ MapReduce Service/ User Guide (Ankara Region)/ Alarm Reference/ ALM-50402 JobGateway Service Unavailable
Updated on 2024-11-29 GMT+08:00

ALM-50402 JobGateway Service Unavailable

Alarm Description

The system checks the JobGateway service status every 60 seconds. This alarm is generated when the JobGateway service is abnormal.

This alarm is cleared when the JobGateway service recovers.

Alarm Attributes

Alarm ID

Alarm Severity

Alarm Type

Service Type

Auto Cleared

50402

Critical

Error handling

JobGateway

Yes

Alarm Parameters

Type

Parameter

Description

Location Information

Source

Specifies the cluster or system for which the alarm is generated.

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

Impact on the System

Users cannot use the job functions related to the JobGateway component. For example, jobs cannot be submitted, terminated, or viewed on the MRS management plane, and MRS job management APIs (V2) cannot be called.

Possible Causes

The node where the JobGateway service locates is faulty.

Handling Procedure

  1. Log in to FusionInsight Manager, choose Cluster > Services > JobGateway, and click the Instance tab. Check for JobServer or JobBalancer instances that are faulty or not started and view the host names of these instances.
  2. On the Alarm page of FusionInsight Manager, check whether the NodeAgent Process Is Abnormal alarm is generated.

    • If yes, go to 3.
    • If no, go to 6.

  3. Check whether the host name in the alarm information is the same as the host name in 1.

    • If yes, go to 4.
    • If no, go to 6.

  4. Clear the alarm by following the instructions provided in ALM-12006 NodeAgent Process Is Abnormal.
  5. In the alarm list, check whether alarm JobGateway Service Unavailable is cleared.

    • If yes, no further action is required.
    • If no, go to 6.

Collect fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. Expand the Service drop-down list, and select JobGateway for the target cluster.
  3. Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact O&M engineers and provide the collected logs.

Alarm Clearance

This alarm is automatically cleared after the fault is rectified.

Related Information

None.