ALM-50401 Number of JobServer Waiting Tasks Exceeds the Threshold
Alarm Description
The system checks the number of jobs submitted to JobServer every 30 seconds. This alarm is generated when the number of jobs to be executed exceeds 800.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
50401 |
Critical (default threshold: 900) Major (default threshold: 800) |
Quality of service |
JobGateway |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster or system for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
|
RoleName |
Specifies the role for which the alarm is generated. |
|
HostName |
Specifies the host for which the alarm is generated. |
Impact on the System
Too many JobServer tasks are detected in the queue. For details about the task queue usage, see the additional information field of this alarm. The impacts are as follows:
- When the number of JobServer tasks in the queue reaches the maximum (1000 by default), new tasks cannot be added.
- Before the number of JobServer tasks in the queue reaches the maximum, new JobServer tasks cannot be submitted quickly. For example, it takes more time (even hours) to submit tasks in the queue or new tasks to YARN. The time for submitting a new task to the Yarn component is prolonged, which may reach the hour level.
Possible Causes
Too many jobs are submitted instantaneously.
Handling Procedure
- Log in to FusionInsight Manager and choose Cluster > Services > JobGateway.
- Click the Instance tab, click Add Instance, and add JobServer instances based on the number of submitted jobs.
- After the instances are added, restart the JobGateway service.
- Wait 5 minutes and check whether the alarm is automatically cleared.
If yes, no further action is required.
If no, go to 5.
Collect fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, and select JobGateway for the target cluster.
- Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M engineers and provide the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None.
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot