What Can I Do If AK/SK Verification Fails?
Symptom
When you tried to register an Edge device to MgC, a message was displayed indicating that the AK/SK authentication failed.
Possible Causes
Possible causes are:
- The entered AK or SK is incorrect.
- The AK/SK pair has been deleted or disabled.
- The programmatic access mode is not enabled for the account that owns the AK/SK pair.
Solutions
- The entered AK or SK is incorrect.
Check whether the entered AK/SK pair of the Huawei Cloud account is correct, especially whether any spaces or characters are missed during the copy. Enter the AK/SK pair for authentication again.
- The AK/SK pair has been deleted or disabled.
Choose My Credentials > Access Keys to check whether the AK is in the list.
- If it is not, use an AK/SK pair in the list for authentication or create an AK/SK pair.
- If it is, check whether it is disabled. If the AK is disabled, enable it.
- The programmatic access mode is not enabled for the account that owns the AK/SK pair.
- Sign in to the management console.
- Click the username in the upper right corner and choose Identity and Access Management.
- In the navigation pane on the left, choose Users and click the username you used for migration.
- Check whether Programmatic access is selected for Access Type. If it is nor, click next to Access Type, select Programmatic Access, and click Yes
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