Help Center/ Migration Center/ Tool Guide/ FAQs/ What Can I Do If the Port Required by Edge Is Occupied and the Installation Fails?
Updated on 2024-12-02 GMT+08:00

What Can I Do If the Port Required by Edge Is Occupied and the Installation Fails?

Symptom

When you tried to install Edge, the following message was displayed: Port used by Edge is occupied. Stop the process that occupies the port and try again.

Possible Causes

The default port 27080 for installing Edge is occupied.

Solution

Stop the application process that occupies port 27080.

Before stopping the application process, evaluate the risks by yourself.

Linux

  1. Query the ID of the application that occupies the port.

    netstat -tlnp | grep 27080

    Assume that the queried application ID is 11083.

  2. Query the application process based on the obtained application ID. The application ID is only an example. Replace it with the actual application ID.

    ps -ef | grep 11083

  3. Confirm that the application occupying the port can be stopped, and run the following command to stop the application process. Then reinstall Edge.

    kill -9 11083

Windows

  1. Open the CLI in Windows and run the following command to query the ID of the application that occupies the port.

    netstat -ano | findstr 27080

    Assume that the queried application ID is 5816. The application ID is only an example. Replace it with the actual query result.

  2. Open the Task Manager. On the Details tab, find the application process based on the queried application ID.
  3. Confirm that the application occupying the port can be stopped, and right-click the application process and choose End task from the shortcut menu to stop the application process. Then reinstall Edge.