Help Center/ Relational Database Service_RDS for PostgreSQL/ FAQs/ Database Connection/ What Should I Do If My RDS for PostgreSQL Instance Fails to Be Connected Due to Client Problems?
Updated on 2026-10-08 GMT+08:00

What Should I Do If My RDS for PostgreSQL Instance Fails to Be Connected Due to Client Problems?

Troubleshoot RDS for PostgreSQL connection failures caused by a client problem by checking the following items:

  • ECS Security Policy

    In Windows, check whether the RDS for PostgreSQL instance port is enabled in the Windows security policy. In Linux, run iptables to check the firewall and port allowlist.

  • Application Configuration

    Check whether the connection address, port parameter configuration, and JDBC connection parameter configuration are correct.

  • Username or Password

    Check whether the username or password is correct if an error similar to the following occurs during RDS DB connection:

    FATAL:  Invalid username/password,login denied.

If the problem persists, submit a service ticket.