Updated on 2022-08-12 GMT+08:00

ALM-25000 LdapServer Service Unavailable

Description

The system checks the LdapServer service status every 30 seconds. This alarm is generated when the system detects that both the active and standby LdapServer services are abnormal.

This alarm is cleared when the system detects that one or two LdapServer services are normal.

Attribute

Alarm ID

Alarm Severity

Auto Clear

25000

Critical

Yes

Parameters

Name

Meaning

Source

Specifies the cluster for which the alarm is generated.

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

Impact on the System

When this alarm is generated, no operation can be performed for the KrbServer users and LdapServer users in the cluster. For example, users, user groups, or roles cannot be added, deleted, or modified, and user passwords cannot be changed on the FusionInsight Manager portal. The authentication for existing users in the cluster is not affected.

Possible Causes

  • The node where the LdapServer service locates is faulty.
  • The LdapServer process is abnormal.

Procedure

Check whether the nodes where the two SlapdServer instances of the LdapServer service are located are faulty.

  1. On FusionInsight Manager, choose Cluster > Name of the desired cluster > Services > LdapServer > Instance to go to the LdapServer instance page to obtain the host name of the node where the two SlapdServer instances locates.
  2. Choose O&M > Alarm > Alarms. On the Alarm page of the FusionInsight Manager system, check whether any alarm of Node Fault exists.

    • If yes, go to 3.
    • If no, go to 6.

  3. Check whether the host name in the alarm is consistent with the 1 host name.

    • If yes, go to 4.
    • If no, go to 6.

  4. Handle the alarm according to "ALM-12006 Node Fault".
  5. Check whether LdapServer Service Unavailable is cleared in the alarm list.

    • If yes, no further action is required.
    • If no, go to 10.

Check whether the LdapServer process is normal.

  1. Choose O&M > Alarm > Alarms. On the Alarm page of the FusionInsight Manager system, check whether any alarm of Process Fault exists.

    • If yes, go to 7.
    • If no, go to 10.

  2. Check whether the service and host name in the alarm are consistent with the LdapServer service and host name.

    • If yes, go to 8.
    • If no, go to 10.

  3. Handle the alarm according to "ALM-12007 Process Fault".
  4. Check whether LdapServer Service Unavailable is cleared in the alarm list.

    • If yes, no further action is required.
    • If no, go to 10.

Collect fault information.

  1. On the FusionInsight Manager, choose O&M > Log > Download.
  2. Select LdapServer in the required cluster from the Service.
  3. Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact the O&M personnel and send the collected logs.

Alarm Clearing

After the fault is rectified, the system automatically clears this alarm.

Related Information

None