Estos contenidos se han traducido de forma automática para su comodidad, pero Huawei Cloud no garantiza la exactitud de estos. Para consultar los contenidos originales, acceda a la versión en inglés.
Actualización más reciente 2023-10-09 GMT+08:00

¿Qué hago si una conexión remota está en el estado de reintento?

Síntoma

Causa posible

La descarga del servidor de VS Code falló antes, lo que llevó a datos residuales. Como resultado, no se puede realizar una nueva descarga.

Solución

Método 1 (realizado localmente): Abra el panel de comandos (Ctrl+Shift+P para Windows y Cmd+Shift+P para Mac), encuentre Kill VS Code Server on Host y localice la instancia afectada, que se borrará automáticamente. Luego, vuelva a establecer la conexión.

Figura 1 Borrar la instancia afectada

Método 2 (realizado de forma remota): Elimine los archivos que se están utilizando en /home/ma-user/.vscode-server/bin/ en el terminal de VS Code. Luego, vuelva a establecer la conexión.

ssh -tt -o StrictHostKeyChecking=no -i ${IdentityFile} ${User}@${HostName} -p ${Port}
rm -rf /home/ma-user/.vscode-server/bin/

Parámetros:

- IdentityFile: Ruta de acceso a la clave local

- User: Nombre de usuario, por ejemplo, ma-user

- HostName: Dirección IP

- Port: Número de puerto

Los métodos anteriores también se pueden utilizar para resolver problemas relacionados con el servidor de VS Code.

Fallas en el acceso al entorno de desarrollo con VS Code Preguntas frecuentes

more