DWS_2000000017 El número de sentencias de consulta de cola supera el umbral
Descripción
Cuando se habilita el monitoreo de consultas en tiempo real, GaussDB(DWS) comprueba el estado de cola de los trabajos en CN a través de la vista GS_WLM_SESSION_STATISTICS cada 60 segundos de forma predeterminada.
Esta alarma se genera cuando el número de sentencias SQL en cola en el clúster supera 10 (configurable) en 10 minutos (configurable), y se borra automáticamente cuando el número de sentencias SQL en cola cae por debajo de 10.
Si sigue habiendo sentencias de consulta en cola más que el umbral de alarma, la alarma se genera de nuevo 24 horas después (configurable).
Atributos de alarma
ID de alarma |
Gravedad de alarma |
Borrar automáticamente |
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DWS_2000000017 |
Crítica |
Sí |
Parámetros de alarmas
Parámetro |
Descripción |
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Alarm Source |
Indica el nombre del sistema para el que se genera la alarma y el tipo de alarma detallado. |
Cluster Name |
ID del clúster para el que se genera la alarma |
Location Information |
ID y nombre del clúster para el que se genera la alarma |
Detail Information |
CloudService indica el servicio en la nube para el que se genera la alarma, incluidos el nombre del servicio, el ID del recurso, el nombre del recurso, la hora de la primera alarma y la información de alarma formateada. Ejemplo: CloudServiceDWS, resourceId=xxxx-xxxx-xxxx-xxxx, resourceIdName=test_dws, first_alarm_time:2023-01-11:19:02:09. El número promedio de sentencias de consulta en cola en el clúster test_dws en 10 minutos es 30, lo que excede el umbral 10. |
Generated |
Hora de generación de la alarma. |
Status |
Indica el estado de la alarma actual. |
Impacto en el sistema
Las consultas SQL están bloqueadas. Como resultado, el tiempo de ejecución es demasiado largo.
Causas posibles
El número de sentencias de consulta de cola durante la ejecución del servicio excede el umbral de alarma.
Procedimiento de manejo
Comprobar si los trabajos en cola actuales en el clúster son normales.
- Inicie sesión en la consola de GaussDB(DWS).
- En la página Alarms, seleccione el clúster actual en la lista desplegable de selección de clúster en la esquina superior derecha y vea la información de alarma del clúster en los últimos siete días. Busque el nombre del clúster que activa la alarma en función de la información de ubicación.
- En la página Clusters, busque la fila que contiene el clúster para el que se genera la alarma y haga clic en Monitoring Panel en la columna Operation.
- Seleccione Monitoring > Queries para ver las sesiones y consultas en tiempo real del clúster actual. Seleccione la pestaña Queries para ver el estado de los trabajos que se ejecutan en el clúster actual. Haga clic en y seleccione estado de Blocking Time (ms) y Waiting. Haga clic en para ordenar los valores de Blocking Time (ms). Puede ver la información sobre las sentencias SQL en espera con el tiempo de bloqueo más largo. Si un trabajo de consulta está en estado de espera y el tiempo de bloqueo es anormal, puede finalizar la consulta.
Estado actual de la cola de las sentencias, que incluye:
- Global: cola global.
- Respool: cola de grupo de recursos.
- CentralQueue: cola en el CCN
- Transaction: estar en un bloque de transacciones
- StoredProc: estar en un procedimiento almacenado
- None: no estar en una cola
- Forced None: se ejecuta a la fuerza (sentencia de bloque de transacción o sentencia de procedimiento almacenado son) porque el tiempo de espera de la sentencia excede el valor especificado
Borrar alarmas.
Esta alarma se borra automáticamente cuando el número de sentencias de cola cae por debajo del umbral.