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Actualización más reciente 2023-08-08 GMT+08:00

¿Por qué no puedo obtener la contraseña para iniciar sesión en mi ECS de Windows autenticado mediante un par de claves?

Síntomas

No se puede utilizar una clave privada para obtener la contraseña para iniciar sesión en un ECS de Windows autenticado mediante un par de claves.

Causas posibles

La contraseña no se puede inyectar usando Cloudbase-Init debido a:
  • Una falla de red que provoca la falla de la conexión del ECS al servidor Cloudbase-Init.
  • No hay configuración en la imagen para que Cloudbase-Init obtenga la contraseña.
  • Otras razones.

Solución

Si el inicio de sesión en un ECS con Cloudbase-Init habilitado falla, realice las siguientes operaciones para localizar el error:

  1. Asegúrese de que Cloudbase-Init se haya configurado correctamente en la imagen que se usó para crear el ECS.
    • Si Cloudbase-Init no se ha configurado, su ECS no permitirá configuraciones personalizadas y solo puede iniciar sesión con la contraseña de la imagen original.
    • Las ECS creadas con una imagen pública tienen Cloudbase-Init instalado de forma predeterminada. Por lo tanto, ya no es necesario instalar y configurar Cloudbase-Init.
    • Si creó su ECS mediante un archivo de imagen externo, instale y configure Cloudbase-Init.

      Para obtener más información, consulte Instalación y configuración de Cloudbase-Init.

  1. Asegúrese de que el par de claves para iniciar sesión en el ECS es correcto.

    La clave utilizada para obtener la contraseña debe ser la clave utilizada durante la creación del ECS.

  2. Asegúrese de que DHCP esté activada en la VPC a la que pertenece el ECS.

    En la consola de gestión, compruebe si DHCP se ha habilitado en la subred de destino.

    Figura 1 DHCP
  3. Asegúrese de que el ECS tiene un enlace de EIP.
  4. Asegúrese de que el tráfico hacia y desde el puerto 80 esté permitido en las reglas de grupo de seguridad.
    Figura 2 Reglas de grupo de seguridad para el puerto 80
  5. Compruebe los registros de Cloudbase-Init para identificar la causa.
    1. Detenga el ECS afectado y desconecte el disco del sistema de él.
      Figura 3 Desconectar el disco del sistema
    2. Utilice una imagen pública para crear un ECS temporal de Windows y conecte el disco del sistema desconectado de 6.a al ECS.
    3. Inicie sesión en el ECS temporal, abra la página Server Manager, elija File and Storage Services > Volumes > Disks, haga clic con el botón derecho en el disco sin conexión y elija Online en el menú contextual.
      Figura 4 Configuración del disco en línea
    4. Cambie al archivo cloudbase-init en /Program Files/Cloudbase Solution/Cloudbase-Init/log de este disco para ver el log para la localización de fallas.
      Figura 5 cloudbase-init