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Actualización más reciente 2023-08-08 GMT+08:00

¿Cómo puedo rectificar la falla cuando el estado del clúster no está disponible?

Si el clúster es Unavailable, realice las siguientes operaciones para rectificar el error:

Localización de fallas

Los métodos de resolución de problemas se ordenan en función de la probabilidad de ocurrencia de las posibles causas. Se recomienda comprobar las posibles causas de alta probabilidad a baja probabilidad para localizar rápidamente la causa del problema.

Si la falla persiste después de rectificar una posible causa, compruebe otras posibles causas.

Figura 1 Localización de fallas

Concepto de comprobación 1: Si el grupo de seguridad está modificado

  1. Inicie sesión en la consola de gestión y elija Service List > Networking > Virtual Private Cloud. En el panel de navegación de la izquierda, elija Access Control > Security Groups para buscar el grupo de seguridad del nodo principal en el clúster.

    El nombre de este grupo de seguridad tiene el formato de Cluster name-cce-control-ID.

  2. Haga clic en el grupo de seguridad. En la página de detalles que se muestra, asegúrese de que las reglas de grupo de seguridad del nodo principal son correctas.

    Para obtener más información acerca de la seguridad, consulte Configuración de reglas de grupo de seguridad de clúster.

Concepto de comprobación 2: Si hay oyentes residuales y grupos de servidores backend en el balanceador de carga

Reproducir el problema

Se produce una excepción de clúster cuando se crea o se elimina un LoadBalancer Service. Después de corregir el error, el Service se elimina correctamente, pero hay escuchas residuales y grupo de servidores backend.

  1. Precree un clúster de CCE. En el clúster, utilice la imagen oficial de Nginx para crear cargas de trabajo, balanceadores de carga preestablecidos, Services y entradas.
  2. Asegúrese de que el clúster se está ejecutando correctamente y que la carga de trabajo de Nginx es estable.
  3. Cree y elimine 10 LoadBalancer Services cada 20 segundos.
  4. Se produce una excepción de inyección en el clúster. Por ejemplo, el pod de etcd no está disponible o el clúster está hibernado.

Causa posible

Hay oyentes residuales y grupos de servidores backend en el balanceador de carga.

Solución

Borre manualmente los oyentes residuales y los grupos de servidores back-end.

  1. Inicie sesión en la consola de gestión y seleccionNetwork > Elastic Load Balance en la lista de servicios.
  2. En la lista de balanceadores de carga, haga clic en el nombre del balanceador de carga de destino para ir a la página de detalles. En la página de ficha Listeners, localice el oyente de destino y elimínelo.
  3. En la página de ficha Backend Server Groups, busque el grupo de servidores backend de destino y elimínelo.