Querying the Offline Analysis of Outbound Call Failure Causes
Interface Method
The request method must be set to POST.
URL
https://IP:PORT/oifde/rest/api/queryRbtRecognitionResult
Request
Parameter |
Type |
Position |
Mandatory |
Description |
---|---|---|---|---|
beginTime |
Long |
Body |
Yes |
Millisecond timestamp of the query start time.
NOTICE:
To ensure efficiency, the interface data is stored in different tables by month. Only the table of the month corresponding to the start time is queried. |
endTime |
Long |
Body |
Yes |
Millisecond timestamp of the query end time. |
tenantId |
String |
Body |
Yes |
Tenant ID. |
pageNum |
Integer |
Body |
No |
Number of pages to be queried. The value starts from 1. The default value is 1. |
pageSize |
Integer |
Body |
No |
Number of records on each page. The maximum value is 1000. The default value is 1000. |
authToken |
String |
Body |
Yes |
Authentication token. For details, see C3 OIAP Interface Authentication. |
Response
Parameter |
Type |
Position |
Mandatory |
Description |
---|---|---|---|---|
rbtRecognitions |
RbtRecognition[] |
Body |
Yes |
Analysis of the outbound call failure cause. |
total |
Integer |
Body |
Yes |
Total number. |
pageSize |
Integer |
Body |
Yes |
Number of records on each page. |
pageNum |
Integer |
Body |
Yes |
Page number, starting from 1. |
Parameter |
Mandatory |
Type |
Description |
---|---|---|---|
rbtRecognitionId |
Yes |
Long |
Result ID. |
callId |
Yes |
String |
Chatbot access volume. |
fileName |
Yes |
String |
Recording file drive path. |
callerNo |
Yes |
String |
Calling number. |
calleeNo |
Yes |
String |
Called number. |
agentId |
Yes |
Integer |
Agent ID. |
recordBeginTime |
Yes |
Long |
Recording start time. |
recordEndTime |
Yes |
Long |
Recording end time. |
callType |
Yes |
Integer |
Call type. The fixed value is 7, indicating manual outbound call. |
mediaType |
Yes |
Integer |
Media type. The fixed value is 5, indicating voice. |
vdnId |
Yes |
Integer |
CTI VDN ID. |
tenantId |
Yes |
String |
Tenant ID. |
callCenterId |
Yes |
Integer |
CTI call center ID. |
releaseCause |
Yes |
Integer |
Release cause. For details, see the CTI product documentation. |
beginTime |
Yes |
Long |
Result input time. |
endTime |
No |
Long |
Result update time. |
result |
No |
Integer |
For details, see Table 3. |
asrTransResult |
No |
String |
ASR result. |
confirmedResult |
No |
String |
Manual confirmation result. |
confirmStatus |
Yes |
Integer |
Manual confirmation status. |
remark |
No |
String |
Remarks. |
locationId |
Yes |
Integer |
Recording node, which is used when the CTI pool is used. |
updateTime |
No |
Long |
Modification time. |
Code |
Cause |
---|---|
-1 |
The recording file name is incorrect. |
-2 |
Failed to download the recording. |
-3 |
Failed to request ASR. |
-4 |
Failed to obtain ASR. |
-5 |
Failed to obtain the intention recognition result. |
101 |
The called number does not exist. |
102 |
The called party has powered off. |
103 |
The called party is busy. |
104 |
The calling number is suspended on arrears. |
105 |
The called number is suspended. |
106 |
The called party is busy and the call has been registered the call waiting service. |
107 |
The called party is busy and the call has not been registered the call waiting service. |
108 |
The called party is unreachable. |
109 |
The called party has subscribed to the call transfer service. |
110 |
The international call is barred. |
111 |
The called party does not answer the call for a long time. |
112 |
The called party has enabled the inbound call barring function. |
113 |
The line of another carrier is faulty. |
114 |
The called party cannot be connected and the inbound call notification function is enabled. |
Example
- Request
{ "beginTime": 1631203200000, "endTime": 1631289540000, "tenantId": "xxxxxx", "pageNum": 1, "pageSize": 100, "authToken": "xxxxxxxxxx" }
- Response
{ "rbtRecognitions": [ { "rbtRecognitionId": 953730645354352640, "callId": "xxxxxxx-xxxx", "fileName": "Y:\\268\\0\\20210908\\2608\\xxxx.V3", "callerNo": "xxxxxxx", "calleeNo": "xxxxxxx", "agentId": 1234, "recordBeginTime": 1631240233000, "recordEndTime": 1631067449000, "callType": 7, "mediaType": 5, "vdnId": 123, "tenantId": "123456789", "callCenterId": 1, "releaseCause": 531, "beginTime": 1631241600000, "endTime": 1631241730000, "result": 105, "asrTransResult": null, "confirmedResult": null, "confirmStatus": 0, "remark": null, "locationId": 0, "updateTime": 1631241730000 } ], "total": 1, "pageSize": 100, "pageNum": 1 }
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