Updated on 2024-01-17 GMT+08:00

ALM-24000 Flume Service Unavailable (For MRS 2.x or Earlier)

Description

The alarm module checks the Flume service status every 180 seconds. This alarm is generated if the Flume service is abnormal.

This alarm is cleared after the Flume service recovers.

Attribute

Alarm ID

Alarm Severity

Auto Clear

24000

Critical

Yes

Parameters

Parameter

Description

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

Impact on the System

Flume cannot work and data transmission is interrupted.

Possible Causes

  • HDFS is unavailable.
  • LdapServer is unavailable.

Procedure

  1. Check the HDFS status.

    1. Go to the MRS cluster details page and choose Alarms.
    2. Check whether the ALM-14000 HDFS Service Unavailable alarm is generated.
      • If yes, clear the alarm according to the handling suggestions of "ALM-14000 HDFS Service Unavailable".
      • If no, go to 2.

  2. Check the LdapServer status.

    Check whether the ALM-25000 LdapServer Service Unavailable alarm is generated.
    • If yes, clear the alarm according to the handling suggestions of "ALM-25000 LdapServer Service Unavailable".
    • If no, go to 3.b.

  3. Check whether the HDFS and LdapServer services are stopped.

    1. Go to the MRS cluster details page and click Components.
    2. In the service list on MRS Manager, check whether the HDFS and LdapServer services are stopped.
      • If yes, start the HDFS and LdapServer services and go to 3.c.
      • If no, go to 4.
    3. Check whether the "ALM-24000 Flume Service Unavailable" alarm is cleared.
      • If yes, no further action is required.
      • If no, go to 4.

  4. Collect fault information.

    1. On MRS Manager, choose System > Export Log.
    2. Contact the O&M engineers and send the collected logs.

Related Information

N/A