Updated on 2024-01-17 GMT+08:00

ALM-25000 LdapServer Service Unavailable (For MRS 2.x or Earlier)

Description

The system checks the LdapServer service status every 30 seconds. This alarm is generated when the active and standby LdapServer services are abnormal.

This alarm is cleared when either of the LdapServer services restores.

Attribute

Alarm ID

Alarm Severity

Auto Clear

25000

Critical

Yes

Parameters

Parameter

Description

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

Impact on the System

When this alarm is generated, no operation can be performed for the KrbServer users and LdapServer users in the cluster. For example, users, user groups, or roles cannot be added, deleted, or modified, and user passwords cannot be changed on MRS Manager. The authentication for existing users in the cluster is not affected.

Possible Causes

  • The node where the LdapServer service locates is faulty.
  • The LdapServer process is abnormal.

Procedure

  1. Check whether the nodes where the two SlapdServer instances of the LdapServer service locate are faulty.

    1. Go to the MRS cluster details page and click Components.
    2. Choose LdapServer > Instances. Go to the LdapServer instance page to obtain the host name of the node where the two SlapdServer instances reside.
    3. On the Alarms page of MRS Manager, check whether the alarm ALM-12006 Node Fault is generated.
      • If yes, go to 1.d.
      • If no, go to 2.a.
    4. Check whether the host name in the alarm information is the same as the actual host name in 1.b.
      • If yes, go to 1.e.
      • If no, go to 2.a.
    5. Rectify the fault by following steps provided in ALM-12006 Node Fault.
    6. In the alarm list, check whether the alarm ALM-25000 LdapServer Service Unavailable is cleared.
      • If yes, no further action is required.
      • If no, go to 3.

  2. Check whether the LdapServer process is in normal state.

    1. Go to the cluster details page and choose Alarms.
    2. Check whether ALM-12007 Process Fault is generated.
      • If yes, go to 2.c.
      • If no, go to 3.
    3. Check whether the service name and host name in the alarm are consistent with the LdapServer service and host names.
      • If yes, go to 2.d.
      • If no, go to 3.
    4. Rectify the fault by following steps provided in ALM-12007 Process Fault.
    5. In the alarm list, check whether the alarm ALM-25000 LdapServer Service Unavailable is cleared.
      • If yes, no further action is required.
      • If no, go to 3.

  3. Collect fault information.

    1. On MRS Manager, choose System > Export Log.
    2. Contact the O&M engineers and send the collected logs.

Reference

None