Updated on 2024-01-17 GMT+08:00

ALM-12053 File Handle Usage Exceeds the Threshold (For MRS 2.x or Earlier)

Description

The system checks the handler usage every 30 seconds. This alarm is generated when the handle usage exceeds the threshold (the default threshold is 80%) for multiple times (the default value is 5).

You can change the threshold by choosing System > Threshold Configuration > Device > Host > Host Status > Host File Handle Usage > Host File Handle Usage.

If the hit number is 1, this alarm is cleared when the file handle usage is less than or equal to the threshold. If the hit number is greater than 1, this alarm is cleared when the file handle usage is less than or equal to 90% of the threshold.

Attribute

Alarm ID

Alarm Severity

Auto Clear

12053

Major

Yes

Parameters

Parameter

Description

ServiceName

Specifies the service for which the alarm is generated.

RoleName

Specifies the role for which the alarm is generated.

HostName

Specifies the host for which the alarm is generated.

Trigger Condition

Specifies the threshold for triggering the alarm.

Impact on the System

The system applications fail to open files, access networks, and perform other I/O operations. The applications are running improperly.

Possible Causes

  • The number of file handles does not meet service requirements.
  • The system is abnormal.

Procedure

Increase the number of file handles.

  1. Go to the MRS cluster details page and choose Alarms.
  2. In the real-time alarm list, click the alarm. In the Alarm Details area, obtain the IP address of the host for which the alarm is generated.
  3. Use PuTTY to log in to the host for which the alarm is generated as user root.
  4. Run the ulimit -n command to check the maximum number of handles set in the system.
  5. If the file handle usage exceeds the threshold, contact the system administrator to increase the number of system file handles.
  6. Wait 5 minutes and check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 7.

Check whether the system environment is normal.

  1. Contact the system administrator to check whether the OS is abnormal.

    • If yes, rectify the operating system fault and go to 8.
    • If no, go to 9.

  2. Wait 5 minutes and check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 9.

  3. Collect fault information.

    1. On MRS Manager, choose System > Export Log.
    2. Contact the O&M engineers and send the collected logs.

Reference

None