Help Center> MapReduce Service> Troubleshooting> Common Exceptions in Logging In to the Cluster Manager> Common Exceptions in Accessing the MRS Web UI> [Hue Web UI] A "No Permission" Error Is Displayed When a User Log In to the Hue Web UI
Updated on 2023-12-22 GMT+08:00

[Hue Web UI] A "No Permission" Error Is Displayed When a User Log In to the Hue Web UI

Symptom

In a cluster with Kerberos authentication enabled, when a user logs in to the Hue web UI as user admin, an error message is displayed, indicating that the user does not have the permission or cannot connect to the Hive server. The system may remind you to check whether the Hive permission of the current user and the Hive configuration of Hue are correct or display message "No available hive server...".

Possible Causes

For clusters with Kerberos authentication enabled, user admin does not have the permission to perform operations the Hue web UI. To solve this problem, you can create a human-machine user (for example, hueuser) and add it to the hive, hadoop, and supergroup user groups and the System_administrator role. The primary group is hive.

Procedure

  1. Log in to FusionInsight Manager.
  2. Choose System > Permission > User.
  3. On the User page, click Create, configure the following information, and retain the default values for other parameters.

    • Username: user-defined, for example, hueuser.
    • User Type: Select Human-Machine.
    • Password and Confirm Password: Enter a password as prompted.
    • User Group: Click Add, select hive, hadoop, and supergroup, and click OK.
    • Primary Group: Select hive.
    • Role: Click Add and select System_administrator.

  4. Click OK.
  5. Access the Hue web UI as the new user (for example, user hueuser).

    Change the password upon the first login.