Help Center> MapReduce Service> Troubleshooting> Common Exceptions in Logging In to the Cluster Manager> Accessing the Web Pages> Error 503 Is Reported When Manager Is Accessed Through Direct Connect
Updated on 2023-06-07 GMT+08:00

Error 503 Is Reported When Manager Is Accessed Through Direct Connect

Symptom

When Manager is accessed through Direct Connect, error 503 is displayed, indicating that the page cannot be used currently.

Possible Causes

As the number of tasks increases or the number of concurrent tasks increases, the Executor memory may be insufficient. As a result, the Manager cannot be accessed.

Procedure

  1. Log in to either the Master1 or Master2 node as user root and run the following command to switch to user omm:

    su - omm

  2. Run the following commands to modify the catalina.sh script:

    vim /opt/executor/bin/catalina.sh

    Search for JAVA_OPTS, find the configuration similar to JAVA_OPTS="-Xms1024m -Xmx4096m", change the value as required, and save the modification.

  3. The manager-executor process only runs on either the Master1 or Master2 node in active/standby mode. Check whether it exists on the node before restarting it.
    1. Log in to the Master1 and Master2 nodes and run the following command to check whether the process exists. If any command output is displayed, the process exists.

      ps -ef | grep "/opt/executor" | grep -v grep

    2. Run the following command to restart the process:

      sh /opt/executor/bin/shutdown.shsh /opt/executor/bin/startup.sh

  4. Log in to the Manager page again.