Help Center> Live> Troubleshooting> Failed to Add a Domain Name
Updated on 2023-07-07 GMT+08:00

Failed to Add a Domain Name

Symptom

When you add an ingest domain name or streaming domain name, an error message is displayed, indicating that the domain name fails to be added.

Possible Causes

  • Cause 1: Your account is in arrears, and the system displays a message indicating that the domain name fails to be added and the user is in the deleted state.
  • Cause 2: The domain name already exists. The message "Failed to add the domain name. The domain name already exists." is displayed.
  • Cause 3: The domain name has not been licensed. A message is displayed, indicating that the domain name fails to be added because the ICP number does not exist.
  • Cause 4: The domain name already exists. A message is displayed, indicating that the domain name fails to be added and data fails to be synchronized to CDN.

Solution for Cause 1

  1. Log in to Billing Center.
  2. On the Overview page, view the available quota.

  3. Click Top Up if your account has any outstanding amount.
  4. Log in to the Live console and add the domain name again.

Solution for Cause 2

Check whether the domain name has been added to other regions or Live accounts. Live does not support duplicate domain names. You are advised to use a new domain name.

Solution for Cause 3

If you add an ingest domain name and streaming domain name in the CN North-Beijing4 region, the domain names to be added must be licensed before they can be used for pushing and playing live streams on the Live console.

All websites with their own domain names that operate inside the Chinese mainland are required to obtain a license. You are advised to have the domain name licensed in the Huawei Cloud ICP License Center. Once you obtain the ICP license, log in to the Live console to add the domain name again.

Solution for Cause 4

You submitted to delete the domain name but add it again before it is completely deleted. In this case, submit a service ticket to contact technical support. Once your problem is solved, you can log in to the Live console to add the domain name again.

If the problem persists, you are advised to submit a service ticket to reach technical support.