Help Center> GaussDB(DWS)> Troubleshooting> Database Connections> Cluster IP Address Cannot Be Pinged/Accessed
Updated on 2024-01-25 GMT+08:00

Cluster IP Address Cannot Be Pinged/Accessed

Symptom

The client host cannot ping the access address of a GaussDB(DWS) cluster.

Possible Causes

  • The network is disconnected.

    If the client host connects to a GaussDB(DWS) cluster using the cluster's private IP address, check whether the client host and the GaussDB(DWS) cluster are in the same VPC and subnet. If they are not in the same VPC or subnet, the network is disconnected.

  • Ping is not allowed in the security group rule.

    The cluster's address can be pinged only when the ICMP port is enabled in the inbound rule of the cluster's security group. By default, only TCP and port 8000 are enabled in the security group that is automatically created during GaussDB(DWS) cluster creation.

    If the ICMP port is enabled in the inbound rule of the security group, check whether the source address in the inbound rule covers the IP address of the client host. If not, the client host cannot ping the cluster.

Handling Procedure

  • The network is disconnected.

    If the client host connects to the data warehouse cluster using the cluster's private IP address, apply for another ECS as the client host. The ECS must be in the same VPC and subnet as the data warehouse cluster.

  • Ping is not allowed in the security group rule.

    View the cluster's security group rule to check whether it enables the ICMP port for the client host's IP address. The operations are as follows:

    1. Log in to the GaussDB(DWS) management console.
    2. On the Cluster Management page, find the target cluster and click its name. The Basic Information page is displayed.
    3. Locate the Security Group parameter and click the security group name to switch to the Security Groups page on the VPC console.
    4. Click the Inbound Rules tab and check whether an inbound rule that enables the ICMP port exists. If such an inbound rule does not exist, click Add Rule to add one.
      • Protocol & Port: Select ICMP and All.
      • Source: Select IP address, and enter the IP address and subnet mask of the client host. 0.0.0.0/0 indicates any IP address.
        Figure 1 Inbound rules
    5. Click OK.