Updated on 2023-01-17 GMT+08:00

Incremental Synchronization Error: schema *** does not exist

Scenarios

During incremental synchronization, an error is reported, and the log information is as follows: service INCREMENT failed, cause by: update %s failed: ERROR: schema ' %s' does not exist.

Possible Causes

  • The filter conditions of DDL statements for adding tables in the source database are not synchronized to the destination database.
  • Schemas are deleted from the destination database.

Solution

  1. Create schemas in the destination database based on the source database structure.
  2. In the task list, locate the target task and click Resume in the Operation column to resume the task.