Updated on 2023-01-17 GMT+08:00

Incremental Phase Error: Lock wait timeout exceeded

Scenarios

During an incremental migration or synchronization, an error is reported, and the log information is as follows: service INCREMENT failed, cause by: Lock wait timeout exceeded; try restarting transaction

Possible Causes

The lock wait times out when the destination database is accessed.

Solution

  1. Contact destination database O&M engineers to check the status and load of the destination database.
  2. In the task list, locate the target task and click Resume in the Operation column to resume the task.